Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    Regular Coder
    Join Date
    Jun 2002
    Location
    Sheffield, UK
    Posts
    552
    Thanks
    0
    Thanked 0 Times in 0 Posts

    running a sessions page thru the validator

    I'm trying to validate my xhtml as on the w3c validator but because my site uses sessions, php shoves PHPSESSID={id} on the ned of every link, and because it uses & intead of & if there's already soemv ars being passed it wont validate.

    Any idea how i can get rid of these for when i'm running the page through the validator?

    TIA
    "To be successful in IT you don't need to know everything - just where to find it in under 30 seconds"

    (Me Me Me Me Me Me Me Me Me)

  • #2
    Senior Coder
    Join Date
    Jun 2002
    Location
    frankfurt, german banana republic
    Posts
    1,848
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Put this at the top of your script.

    PHP Code:
    ini_set('arg_separator.output''&'); 
    De gustibus non est disputandum.

  • #3
    Regular Coder
    Join Date
    Jun 2002
    Location
    Sheffield, UK
    Posts
    552
    Thanks
    0
    Thanked 0 Times in 0 Posts
    hmmm, i really should look into more of the ini settings lol.

    Any idea how to fix the auto generated hidden input field in my form to be XHTML valid?
    "To be successful in IT you don't need to know everything - just where to find it in under 30 seconds"

    (Me Me Me Me Me Me Me Me Me)


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •