Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Mar 2012
    Posts
    33
    Thanks
    1
    Thanked 1 Time in 1 Post

    Help installing pecl

    I have downloaded the uploadprogress.dll and put it into the ext directory in my php directory etc...

    I have also put:
    extension=uploadprogress.dll
    Into the php.ini file and saved.

    Restarted wamp server.

    On the PHP extentions menu in wamp the extention is there and ticked saying that it is ready to be used but when i put:
    PHP Code:
    <?php
    phpinfo
    ();
    ?>
    And view the page uploadprogress is not there.

    Can anyone help me on this?
    Thanks in advance.

  • #2
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,979
    Thanks
    4
    Thanked 2,659 Times in 2,628 Posts
    What extension is this for?
    Typically PHP extensions are branded under php_xxxx.dll/.so. I'm curious if this is a direct extension or if its a supporting DLL that's to be loaded as well as the extension. If this is the case, it needs to be a part of the system path, so either modify the environment and add it into the path, or place it in an existing like system32.

    Make sure you check the apache error logs as well. It should have an indication on startup as to what it did with that dll.

  • #3
    New Coder
    Join Date
    Mar 2012
    Posts
    33
    Thanks
    1
    Thanked 1 Time in 1 Post
    Sorry i typed into php.ini this:
    extension=php_uploadprogress.dll

    I downloaded it from here if it helps:
    http://www.topdll.com/download/php_u...11956713d2be2c

  • #4
    New Coder
    Join Date
    Mar 2012
    Posts
    33
    Thanks
    1
    Thanked 1 Time in 1 Post
    Also in the apache error log i have this:

    PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.10/ext/php_uploadprogress.dll' - %1 is not a valid Win32 application.\r\n in Unknown on line 0
    <br />
    <b>Warning</b>: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.10/ext/php_uploadprogress.dll' - %1 is not a valid Win32 application.
    in <b>Unknown</b> on line <b>0</b><br />
    [Tue Jun 05 11:11:17 2012] [notice] Child 4076: Child process is running

  • #5
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,979
    Thanks
    4
    Thanked 2,659 Times in 2,628 Posts
    The extension indicates that its not a valid win32 application. Its not usable as is, but doesn't describe the issue. Could be the version of Apache in use depending on what was used to build the dll in the first place.
    I don't know what wamp is built on, but if its the older versions of apache then you'll need an older version of the binary to match the VC6 build. Otherwise, that's probably built in VC9. I don't know if the download comes with a readme, but it should be there somewhere.
    Alternatively, you can download the source from pecl directly and compile it in VS to match your Apache build as well.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •