Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    Oct 2011
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    wordpress problem: exporting site and installing on new address

    Hi

    I try to export a wordpress site I have and install it on my pc at localhost/newsite (localhost can be another domain in the future).
    After I fixed all, the site’s homepage loads, but when I click a page, i get to the page’s url back it displays localhost main panel (all the folders etc…)
    I use wamp.
    WP ver 3.3.1

    What I did:
    1. Search replaced all domain.com to localhost/newsite
    2. On wp-config.php I changed the DB definitions from the domain.com server to the localhost DB.
    3. Then went to localhost’s phpmyadmin and imported the DB.

    What am I missing here?
    Why do the pages display the localhost admin panel instead of the page content (and show the page’s url)?

    Can anyone help here?

  • #2
    Master Coder
    Join Date
    Jun 2003
    Location
    Cottage Grove, Minnesota
    Posts
    9,468
    Thanks
    8
    Thanked 1,085 Times in 1,076 Posts
    Have you done anything with the .htaccess file?

  • #3
    New Coder
    Join Date
    Oct 2011
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    ok,found the problem.
    I think it might be a WP bug.
    it turns out i did everything correctly.
    but after installation, i had to go the the permalinks settings, and just click save (dont change anything, just click save and everything worked fine).


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •