Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    Jul 2008
    Posts
    74
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Help with $_REQUEST and & sign

    Hi
    I am passing a variable in the URL and using $_REQUEST to get the value of the variable.
    The variable is a product name and contains a string such as "black", "red" or "black & gold".
    Most of the values are returned correctly except those the contain an & sign. The & sign and everything after it are dropped from the string.

    Is there a cure for my problem.

    Thanks
    Rob

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    When you pass the data in the url use urlencode on the data then when you retrieve it use urldecode.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • Users who have thanked _Aerospace_Eng_ for this post:

    robbiez (02-01-2010)

  • #3
    New Coder
    Join Date
    Jul 2008
    Posts
    74
    Thanks
    8
    Thanked 0 Times in 0 Posts
    Excellent Job
    Many Thanks


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •