Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Nov 2009
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Exclamation PHP Mail() Function Not Working

    I've already set the SMTP server and port, both which work perfectly fine with my email client, why isn't it working? Whenever I try to send mail using the function I get the following error:

    Warning: mail() [function.mail]: Failed to connect to mailserver at "smtp1@bethere.co.uk" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\wamp\www\admin\create-user.php on line 149
    Those are the correct settings, I use them with my email client

  • #2
    Senior Coder tomws's Avatar
    Join Date
    Nov 2007
    Location
    Arkansas
    Posts
    2,644
    Thanks
    29
    Thanked 330 Times in 326 Posts
    "smtp1@bethere.co.uk" is not the name of a mail server or any other server. Email addresses use the @ sign. Server names do not.
    Are you a Help Vampire?

  • Users who have thanked tomws for this post:

    Emkay (11-04-2009)

  • #3
    New to the CF scene
    Join Date
    Nov 2009
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by tomws View Post
    "smtp1@bethere.co.uk" is not the name of a mail server or any other server. Email addresses use the @ sign. Server names do not.
    Argh stupid me. Changed the @ symbol into a period and the problem is fixed...thanks for that lol.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •