Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    Regular Coder student101's Avatar
    Join Date
    Nov 2007
    Posts
    634
    Thanks
    80
    Thanked 15 Times in 15 Posts

    FCKeditor File Manager path issue?

    I managed to find an Ajax File Manager Plugin for FCKeditor, my paths are different.

    Using WAMP;
    sitename\fckeditor\uploadfiles
    On Host; //pretty similar
    root\fckeditor\uploadfiles

    Ajax filemanager in FCKeditor

    define('CONFIG_SYS_DEFAULT_PATH', $_SERVER['DOCUMENT_ROOT'].sitename/fckeditor/uploadfiles/' ; ) ;//accept relative path only
    define('CONFIG_SYS_ROOT_PATH', $_SERVER['DOCUMENT_ROOT'].sitename/fckeditor/uploadfiles/' ; ) ;//accept relative path only


    This works as far as uploading goes but there is a lightbox feature in the filemanager that loads the ajaxloading.gif and no image.

    Any ideas?
    Thanks for your support!
    Update MySQL with checkboxes | Tell A Friend | Delete MySQL with checkboxes

    Give thanks & resolve when done :thumbsup:

  • #2
    Senior Coder tomws's Avatar
    Join Date
    Nov 2007
    Location
    Arkansas
    Posts
    2,644
    Thanks
    29
    Thanked 330 Times in 326 Posts
    Is the filemanager actually looking in the uploads directory for a loading image? I doubt it. Check the code in firebug to see where the manager thinks the image should be located.

    Also, check the documentation for the manager to confirm that its root path should point to the uploads directory. Seems strange.
    Are you a Help Vampire?

  • Users who have thanked tomws for this post:

    student101 (10-28-2009)

  • #3
    Regular Coder student101's Avatar
    Join Date
    Nov 2007
    Posts
    634
    Thanks
    80
    Thanked 15 Times in 15 Posts

    Question

    I used firebug and now I see that it has two // slashes?
    http://localhost:81/sitename/fckeditor/editor//plugins/ajaxfilemanager/ajaxfilemanager.php

    Only question(s)
    Where or How did that get there?

    Edit:
    Funny thing did nothing and those slashes are gone?
    Still no luck.
    Last edited by student101; 10-28-2009 at 04:51 PM.
    Thanks for your support!
    Update MySQL with checkboxes | Tell A Friend | Delete MySQL with checkboxes

    Give thanks & resolve when done :thumbsup:

  • #4
    Senior Coder tomws's Avatar
    Join Date
    Nov 2007
    Location
    Arkansas
    Posts
    2,644
    Thanks
    29
    Thanked 330 Times in 326 Posts
    The extra slash shouldn't cause a problem. (Well, it doesn't on my Linux/Apache pair, anyway.)

    The path you showed isn't a path to an image.
    Are you a Help Vampire?

  • #5
    Regular Coder student101's Avatar
    Join Date
    Nov 2007
    Posts
    634
    Thanks
    80
    Thanked 15 Times in 15 Posts
    Firebug shows this; which is correct...
    C:/wamp/www/sitename/fckeditor/uploadfiles/files/thumbs/4.jpg
    the lightbox type feature shows this
    c:/wamp/www/sitename/fckeditor/uploadfiles/files/thumbs/4.jpg

    In the .js file the reference I get;
    showThickBox(linkElem, appendQueryString(path, 'KeepThis=true&TB_iframe=true&height=' + thickbox.height + '&width=' + thickbox.width));}

    Edit:
    It's working now! YAY!!!
    Only problem all I think I did was change the paths to ../../../uploadfiles/
    Last edited by student101; 10-28-2009 at 05:25 PM.
    Thanks for your support!
    Update MySQL with checkboxes | Tell A Friend | Delete MySQL with checkboxes

    Give thanks & resolve when done :thumbsup:


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •