Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New to the CF scene
    Join Date
    Sep 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    PHP Not Working in a Single Directory

    For some reason a few minutes ago my PHP stopped being interpreted, but only in one directory (and its subdirectories). In all other directories it seems to be working fine. Also, HTML in the troubled directory still displays. On pages with a mix of HTML and PHP the output just stops once a <?php ...?> tag is hit.

    There was a (seemingly harmless) .htaccess file in that folder, but I deleted it and still nothing.

    I am running XAMPP on a Mac.

    Any ideas? I'm about to throw my computer through the window.

    Thanks.

  • #2
    Regular Coder
    Join Date
    Mar 2006
    Posts
    238
    Thanks
    3
    Thanked 37 Times in 37 Posts
    If output has stopped at <?php, probably you have an error there but the error output is suppressed.

    I would add the following lines at the very top some of the scripts which contains PHP code and which stopped working:
    PHP Code:
    <?php
    error_reporting
    (E_ALL);
    ini_set('display_errors','1');
    ?>
    Of course you would need to comment or remove these lines in the Production environment when debugging is over.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •