Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    Sep 2002
    Location
    UK
    Posts
    65
    Thanks
    1
    Thanked 0 Times in 0 Posts

    PHP + Apache Oddness

    Ok i have a little problem with PHP and Apache

    i was using Apache 2 and PHP 4.3. I am not anymore.

    Now my reason for this is that when i uploaded them to my web host runing apache 1.3.somthing i noticed the addslashes() function was no longer working!!!!

    So i decided to experiment for myself. I am no running Apache 1.3.somthing and low and behold addslashes() does not work!!!!

    So basically my problem is this. Is there something else i need to enable in my PHP.ini to get PHP to do the adding of slashes, becuase i'll be damned if i know how.

    The other thing on a side note anyone know how to configure PHP from a .htaccess file i know it can be done know any tutorials?

  • #2
    Senior Coder
    Join Date
    Jun 2002
    Location
    frankfurt, german banana republic
    Posts
    1,848
    Thanks
    0
    Thanked 0 Times in 0 Posts
    IIRC support for Apache2 is still experimental and their are some issues with it. I don't know though if the addslashes() function is one of those things affected.

    In what manner does the erroneous behaviour of addslashes() manifest? I mean, does your server crash, do you get a fatal error or are simply no slashes added to the string? Have you got some source code that we can have a look at?

  • #3
    New Coder
    Join Date
    Sep 2002
    Location
    UK
    Posts
    65
    Thanks
    1
    Thanked 0 Times in 0 Posts
    i just get no slashes added to my strings, which i must say is most odd and more than irritating :S


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •