Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    Jun 2007
    Posts
    13
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Question Isn't GD included in PHP 5.0 ?

    I tried using image functions in PHP 5.0 on my computer with Apache 2.0 installed. And I got an error message like this :
    Fatal error: Call to undefined function imagecreate() in C:\Prog\SERVER\DocumentRoot\WEBSITE\test.php on line 30
    Doesn't PHP 5.0 support GD library? Or is it deactivated by default? Do I have to modify PHP.ini?

    If it doesn't support, how can I install GD library?

  • #2
    New Coder
    Join Date
    Aug 2007
    Location
    Wagga, Australia
    Posts
    59
    Thanks
    0
    Thanked 1 Time in 1 Post
    in windows you must uncomment the
    Code:
    ;extension=php_gd2.dll
    to
    Code:
    extension=php_gd2.dll
    in Unix platforms you must compile php 5.0 with the GD library or make sure you have downloaded a package with the GD library compiled with it.

  • #3
    New Coder
    Join Date
    Jun 2007
    Posts
    13
    Thanks
    6
    Thanked 0 Times in 0 Posts
    Thank you, i couldn't guess it would be so simple.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •