Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    Regular Coder
    Join Date
    Aug 2002
    Location
    Oregon, United States of America
    Posts
    882
    Thanks
    1
    Thanked 9 Times in 9 Posts

    Exclamation PHP -> RSS Headache [FIXED]

    No matter what I do I cannot get any RSS code to come up as an RSS feed in IE7 when it is generated by PHP. In Firefox it works perfectly, but IE just shows the XML code.

    I have this line in my htaccess file working great:
    Code:
    AddType application/x-httpd-php .xml
    And this code, copied partly from another feed that works in IE:
    PHP Code:
    <?php header("Content-Type: application/xml; charset=ISO-8859-1"); ?>
    <?php 
    echo '<?xml version="1.0" encoding="utf-8"?>'?>

    <rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:cf="http://www.microsoft.com/schemas/rss/core/2005">
    <channel xmlns:cfi="http://www.microsoft.com/schemas/rss/core/2005/internal" cfi:lastdownloaderror="None">
        <title cf:type="text">IsuggestU RSS Blog Feed</title>
        <link>http://www.isuggestu.com/</link>
        <description cf:type="text">Keeping you up to date!</description>

        <item>
            <guid isPermaLink="false">http://www.google.com</guid>
            <title xmlns:cf="http://www.microsoft.com/schemas/rss/core/2005" cf:type="text">Blog Entry Test</title>
            <link>http://www.google.com</link>
            <category>Entries By Wes</category>
            <author>valve</author>
            <atom:author xmlns:atom="http://www.w3.org/2005/Atom">
                <atom:name>valve</atom:name>
            </atom:author>
            <description xmlns:cf="http://www.microsoft.com/schemas/rss/core/2005" cf:type="html">
                Description goes here!
            </description>
            <cfi:id>22</cfi:id>
            <cfi:read>true</cfi:read>
            <cfi:downloadurl>http://www.isuggestu.com/rss.xml</cfi:downloadurl>
            <cfi:lastdownloadtime>2007-08-10T10:15:24.093Z</cfi:lastdownloadtime>
        </item>
    </channel>
    </rss>
    Like I said I have no idea why this won't work in IE. Nothing I do will work and i'm pulling my hair out. PLEASE HELP!
    Last edited by Ultragames; 08-12-2007 at 03:07 AM.
    If I'm postin here, I NEED YOUR HELP!!

  • #2
    Super Moderator Inigoesdr's Avatar
    Join Date
    Mar 2007
    Location
    Florida, USA
    Posts
    3,638
    Thanks
    2
    Thanked 404 Times in 396 Posts
    Works in IE7.

  • #3
    Regular Coder
    Join Date
    Aug 2002
    Location
    Oregon, United States of America
    Posts
    882
    Thanks
    1
    Thanked 9 Times in 9 Posts
    I cleared the cache and it finaly works. What a nightmare!

    Can someone here explain the T and the 3Z in the date line mean?
    Code:
    2007-08-10T10:15:24.093Z
    Last edited by Ultragames; 08-12-2007 at 02:57 AM.
    If I'm postin here, I NEED YOUR HELP!!

  • #4
    Super Moderator Inigoesdr's Avatar
    Join Date
    Mar 2007
    Location
    Florida, USA
    Posts
    3,638
    Thanks
    2
    Thanked 404 Times in 396 Posts
    I think the T is meant to indicate that the time is starting; I'm not sure about the Z. It might be a timezone setting.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •