Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New Coder
    Join Date
    Jan 2007
    Posts
    26
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Mod rewrite rule! giving me a 500 internal server error!

    Hey all, i have searched the forum and cant find the solution to my problem. I want a mod rewrite rule to convert index/12/13/14 to index.php?p=12&a=13&s=14 but i have the following code:

    PHP Code:
    RewriteEngine on
    RewriteRule index
    /(.*)/(.*)/(.*).htmlindex.php?p=$1&a=$2&s=$
    but this provides a 500 internal server error
    any help would be greatly appreciated

    jim

  • #2
    New Coder
    Join Date
    Oct 2006
    Posts
    38
    Thanks
    0
    Thanked 0 Times in 0 Posts
    This error occurs in the final step above when the client receives an HTTP status code that it recognises as '500'.
    It's an error with your web server providers.
    Contact them and tell them about your error.


    Shaffer.

  • #3
    Senior Coder
    Join Date
    Apr 2005
    Location
    Colorado, United States
    Posts
    1,208
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Your rewrite rule is broken, that's why Apache is returning a 500 error. Probably the lack of an escape for the period in .html.
    "$question = ( to() ) ? be() : ~be();"

  • #4
    New Coder
    Join Date
    Jan 2007
    Posts
    26
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Its running from localhost, so the server is my own really..

    Also ive noticed i dont actually need the .html part, but with the following code im still havinmg troubles

    Code:
    Options +FollowSymlinks
    RewriteEngine on
    RewriteRule ^index/(.*)/(.*)/(.*)/?$ index.php?p=$1&a=$2&s=$3

  • #5
    New Coder
    Join Date
    Jan 2007
    Posts
    26
    Thanks
    1
    Thanked 0 Times in 0 Posts
    just looked at my error logs and found:

    [Tue Jan 23 19:54:45 2007] [alert] [client 127.0.0.1] c:/program files/easyphp1-8/www/hta/.htaccess: Invalid command 'RewriteEngine', perhaps mis-spelled or defined by a module not included in the server configuration
    Any ideas??

  • #6
    New Coder
    Join Date
    Jan 2007
    Posts
    26
    Thanks
    1
    Thanked 0 Times in 0 Posts
    whey hey! it was a problem with EasyPHP configurations


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •