Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    Jul 2012
    Location
    UK
    Posts
    38
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Setting up CGI on a Mac Os X..

    Hello!

    Latley i have been trying to set up CGI on my Mac, so i followed these instructions: http://www.cgi101.com/book/connect/mac.html
    everything was perfect. I could see no worries about "ooh, maybe i have done that bit wrong", i was quite sure i got it right!
    so when i went to "localhost/~casparwylie/first.cgi
    it did NOT display how i wanted it to, it looked like a txt file of the code, the perl code was just displayed on the browser without it responding as an actual program, i am stumped. How do i fix this? if you have any questions, or requests to see code, etc, please ask!

    Thanks!

  • #2
    Regular Coder
    Join Date
    Jun 2012
    Location
    Near Chicago, USA
    Posts
    123
    Thanks
    7
    Thanked 19 Times in 19 Posts
    This is just a guess. Try putting your test script into the /cgi-bin/ subdirectory.

    I don't know where the http.conf file would be. The file might be updated to allow scripts to run in any public HTTP directory.

    Will

    P.S. I use MAMP, something you may wish to consider.
    Numerology API for apps - Facebook, iPad, mobile phones. No charge to use API. [info]

  • #3
    New Coder
    Join Date
    Jul 2012
    Location
    UK
    Posts
    38
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks!!, but i have tried that!...


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •