Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New Coder
    Join Date
    Jan 2010
    Posts
    79
    Thanks
    1
    Thanked 0 Times in 0 Posts

    404 not found with perl/cgi script

    I writed my home.html page in /var/www with following form:
    <form action="/cgi-bin/login.cgi" method="get" class="form-font">
    <label>Already you registered?</label><br/><hr/><br/>
    <fieldset><br/>
    <legend>Insert your account</legend>
    Email: <input type="text" name="email"/><br/><br/>
    Password: <input type="text" name="password"/><br/><br/>
    <input type="submit" value="Log In" /><br/><br/>
    </fieldset>
    </form>
    I my login.cgi script in /usr/lib/cgi-bin directory. When I log in my home.html page, then firefox return 404 not found:
    Not Found

    The requested URL /process.cgi was not found on this server.
    Apache/2.2.12 (Ubuntu) Server at localhost Port 80
    What is the problem? I typed /cgi-bin/login.cgi and not process.cgi.

  • #2
    Master Coder
    Join Date
    Dec 2007
    Posts
    6,682
    Thanks
    436
    Thanked 890 Times in 879 Posts
    Quote Originally Posted by dark0s View Post
    I writed my home.html page in /var/www with following form:

    I my login.cgi script in /usr/lib/cgi-bin directory. When I log in my home.html page, then firefox return 404 not found:

    What is the problem? I typed /cgi-bin/login.cgi and not process.cgi.
    is a redirection from login.cgi to process.cgi.
    look inside login.cgi for a redirection line and if is not look for a server redirection, htacces or something like that.

    best regards


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •