Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Nov 2004
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    SSI help please .htaccess errors

    I am trying to get SSI to work w/o having shtml extensions. I don't want to have to rename a whole heck of a lot of pages.

    I found a temp fix that will work for now, until I figure something out.

    I have a navigation menu across the top of my website, and that is what I am using the SSI for.

    I tried to create a .htaccess file with these lines:

    AddType text/html .shtml .html .htm
    AddHandler server-parsed .shtml .html .htm
    Options Indexes FollowSymLinks Includes
    However, every time I try it, I get a 500 Internal Server Error.
    Quote Originally Posted by 500 Internal Server Error
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, and inform them of the time the error occurred and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache Server at dakuda.com
    So then I replace the .htaccess file with a new, blank one.

    WIth the blank one, it works as long as I change every fricking extension to .shtml, and then I have to change every fricking link to .shtml.

    ANyone know what the heck I am doing wrong.

    My host is www.globat.com, and they say they support SSI.

    My website is http://www.dakuda.com

    Thanks Chris

  • #2
    Senior Coder
    Join Date
    Jul 2004
    Location
    New Zealand
    Posts
    1,315
    Thanks
    0
    Thanked 2 Times in 2 Posts
    I have
    Code:
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml

  • #3
    New to the CF scene
    Join Date
    Nov 2004
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    DO you have .html or .shtml extensions on your web pages?

    Edit: nevermind, that gives me the same error...


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •