Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    May 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Need help with PhpEclipse and Xampp

    First, forgive the ADD-ness.
    I am trying to do a project as in intern to set up a shopping cart for Jimmy John's to order receipt rolls. Never mind that issue right now... I can't remember much from my PHP class about how to get a local testing server set up. Before I used Dreamweaver in CS3 with XAMPP but this company is too cheap to buy development tools so I'm using the next best thing (probably the better thing). I have XAMPP running Apache and i am using Eclipse to write my php files. When I try to execute and Debug, I get a 404 Object not found. Can someone tell me how to configure things so I can see my output in the browser?

  • #2
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,978
    Thanks
    4
    Thanked 2,659 Times in 2,628 Posts
    Same setup with mine, except I don't use XAMPP and went straight for the mysql/apache/php installs. I haven't used DW in over a year, but personally (I'm a mainly backend person, so keep that in mind) I prefer the eclipse over it - free is a bonus

    Is the error you're receiving as a console result, or is it a popup? The only problems I've had in the past is with the popups, and I also found that the run (not the debug) has issues with using intercepting filters (a pattern I built, it doesn't like to run through it so I have to debug or do it though cli / browser). As for the popup dialog it gives, I've received this when I didn't properly configure the plugin for eclipse.

    The best suggestion I can make for trying right now would be to upgrade the zend plugin. Help > Software Updates > Manage Configuration > In the tree select the Zend debugger > Scan for updates. I believe the newest is 5.2.15, though I'm using the 5.2.12 - I had configuration issues with 5.2.15, so I'm waiting for a PHP5.3 compatible plugin (so I can run namespaces without the editor complaining).
    Also note that if you need to make use of external resources (such as mysql/mysqli or other database extensions), you'll need to alter the ini file in the plugin folder or change the path for the ini to a current one using Window > Preferences > PHP > PHP Executables, or by reconfiguring the cli with the necessary extension loading. The default one is bold, but I've found that it won't let me edit the default ones, but you can create you're own. I have mine setup with the executable path to the plugin's php-cgi.exe, and the ini set to my server's php.ini fle.

    I believe that this environment is actually independent of you're apache environment. I have run through the eclipse with apache off, and it seemed to work just fine.

    Hope that helps!
    PHP Code:
    header('HTTP/1.1 420 Enhance Your Calm'); 

  • #3
    New to the CF scene
    Join Date
    Sep 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    This is my first attempt at using php eclipse.
    when I try to create a php file, I get an error "this file system does not support deletion"
    I am using windows vista.


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •