Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Feb 2005
    Posts
    41
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Script not changing 'element' background colour

    Hi guys,

    I have come across a problem I don't understand and cannot find an answer to anywhere here.

    I am working on a fairly complicated webpage that basically builds and displays array objects.

    A link to the page is here. Warning it takes ages to load but it is still only a development page.
    http://83.227.151.153/doozer/test/deckbuild.php

    As you can see it is really wordy so I haven't included any code here.

    The problem I cannot find a solution to is the imagechange function script.

    When you click on any of the elements in either the cardlist DIV or the armycell or actioncell TABLE CELLS they should change the image in the centre of the page AND the background color of BOTH (i.e. cardlist and #cell versions) should change to red. Only the element in the cardlist DIV changes. The elements in the tables keep their black background.

    I am assuming it is the fact that the elements are maybe embedded in table tags that is the problem but I don't know why this should be the case and I sure as heck don't know how to fix it.

    Having reread this post I realise it may not be clear what I mean so here is how to view the problem.
    After the page (eventually...) loads select DWARF VICTORY in the topleft select box.
    This will fill the right part of the screen with 2 lists.
    Scroll the (huge) list on the far left of the screen down so that BARAKS BRAWLERS is roughly in the centre of the screen.
    Click on the text BARAKS BRAWLERS on either the left or right side of the screen and you will see the left text gets a shiny red background.

    P.S. the links to the images are broken on this development screen which is why the centrescreen image is not changing.

    Here hoping one of you guys can help.

  • #2
    Senior Coder
    Join Date
    Jul 2004
    Location
    New Zealand
    Posts
    1,315
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Fatal error: Maximum execution time of 30 seconds exceeded in C:\webs\doozer\test\deckbuild.php on line 120
    You have bigger problems than a simple change in background colour..
    Forget style. Code to semantics. Seperate style from structure, and structure from behaviour.
    I code to specs, and test only in Firefox (unless stated otherwise).

  • #3
    New Coder
    Join Date
    Feb 2005
    Posts
    41
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Homebond

    this does not happen on my system

    I'm running IE6 in windows ME.
    What are you using?

  • #4
    New Coder
    Join Date
    Feb 2005
    Posts
    41
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Time out error

    Just in case any of you guys like homebond were getting the time out error above I've reset the php processing time limit on the page to hopefully prevent this.

  • #5
    Senior Coder
    Join Date
    Jul 2004
    Location
    New Zealand
    Posts
    1,315
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by doozer
    Just in case any of you guys like homebond were getting the time out error above I've reset the php processing time limit on the page to hopefully prevent this.
    That's not the way to correct this problem.

    Also, there is no "Dwarf Victory" in the top left select box, and nothing happens when I select another option.
    Forget style. Code to semantics. Seperate style from structure, and structure from behaviour.
    I code to specs, and test only in Firefox (unless stated otherwise).


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •