Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    New to the CF scene
    Join Date
    Jun 2004
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Can't get Pop-it menu running in IE

    This site's a great resource. I've swiped a couple snippets from here before and this is the first time I've had trouble with something. I've fairly thoroughly searched the forums but have found no discussion of the following problem:

    It's the Pop-it menu -- http://dynamicdrive.com/dynamicindex1/popit.htm -- and it runs like a panther in Netscape 7.02, but when I open the same page in IE (6.9.2800.1106) the page opens but the pop ups don't work. I get a string of error messages, asking if I wanna debug, as it opens and the same message appears anytime I mouseover one of the menu items.

    The message is:

    A runtime Error has occured.
    Do you wish to Debug?
    Line: 93 (the line number varies depending on where it encounters the following
    Error: 'menuobj.thestyle' is null or not an object


    I can see the offending expression throughout the javascript on page I'm working on, but have no idea what to do about it. Can somebody help me out.

    I've stuck a copy of the offending page here:
    http://ohiodnr.com/recycling/locatio...searchtest.htm

    I'm working in the little dark teal horizontal navigation bar.

    None of the search functionality below is working at this point.

    Thanks in advance for any consideration you can give this question.

    I've got the style stuff stuck in a style sheet but otherwise I cobbled it together by the instructions.

  • #2
    Supreme Master coder! glenngv's Avatar
    Join Date
    Jun 2002
    Location
    Philippines
    Posts
    11,030
    Thanks
    0
    Thanked 247 Times in 244 Posts
    You have 2 div menus with the same id "popmenu".
    Actually, you can't have multiple elements with the same id. Ids are supposed to be unique. I'm surprised it works in NS7 and Moz.

    Try removing the other one.

  • #3
    New to the CF scene
    Join Date
    Jun 2004
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Oh! Excellent! I'll give that a try and get right back to you.

  • #4
    New to the CF scene
    Join Date
    Jun 2004
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you! Thank you! That did it.
    Fiddling around in ignorance, I managed to bust how the pop-up menus open (not all the way), but I think I can un-screw that up.

    Thank you again. I'm off to the "who's the most helpful user" poll.

  • #5
    New to the CF scene
    Join Date
    Jun 2004
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by billmonaghan
    Thank you! Thank you! That did it.
    Fiddling around in ignorance, I managed to bust how the pop-up menus open (not all the way), but I think I can un-screw that up.

    Thank you again. I'm off to the "who's the most helpful user" poll.
    Thanks again glenngv! What you sed about ids tipped me to the problem I was having on our development server. I'm pretty strictly self-taught at this stuff and never understood the whole "one id per page" only thing, since it seemed to work OK. I knew someday I'd pay for that mistake.

  • #6
    Banned
    Join Date
    Sep 2003
    Posts
    3,620
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by billmonaghan
    Thank you! Thank you! That did it.
    Fiddling around in ignorance, I managed to bust how the pop-up menus open (not all the way), but I think I can un-screw that up.

    Thank you again. I'm off to the "who's the most helpful user" poll.
    While you are at it. Could you please update your cross-post in the Dynamic Drive Script Help forum to reflect that you have found the solution here.

    Cheers;
    .....Willy

  • #7
    New to the CF scene
    Join Date
    Jun 2004
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Oh, yes. When I saw someone else had replied it occurred to me I left that question floating in two places.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •