Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Sep 2011
    Posts
    25
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Javascript module not wokring

    Hi All,

    I'm not sure if this is the right place to ask but hope you can help me out. I'm building a new website in Joomla and created my template and menu with jquery. Now i installed a module called widgetkit that has a lot of javascript code. The module should display a rotating banner or tabs but it's not showing anything the problem is that it does show when i put the default template on.

    I'm not a javascript expert but i think it has a conflict with another thing that is running.

    http://rrdesign.nl/widget.html

    Hope someone can help me out.

    Kind Regards,

    Rein

  • #2
    Supreme Master coder! Old Pedant's Avatar
    Join Date
    Feb 2009
    Posts
    25,133
    Thanks
    75
    Thanked 4,338 Times in 4,304 Posts
    Use your debugger and look at the error console.

    Chrome debugger, for example, shows these errors:
    Code:
    not found: resource://jid1-ryetb1dajacauw-at-jetpack-paypal_wishlist_and_notifier-data/stylesheets/notifications.css
    
    Uncaught TypeError: Object [object Object] has no method 'slideshow'   widgetkit-5bdb987f.js:14
    So your "notifications.css" does not exist, so far as the browser can find it.

    And you have an error in the JS code, as noted. No idea why the JS error. You will probably have to ask the widgetkit people.
    An optimist sees the glass as half full.
    A pessimist sees the glass as half empty.
    A realist drinks it no matter how much there is.

  • #3
    New Coder
    Join Date
    Sep 2011
    Posts
    25
    Thanks
    7
    Thanked 0 Times in 0 Posts
    Thank for your reply.
    I checked my firebug but i can't really find what's wrong. I installed another slideshow module and it also doesn't appear.

    Code:
    TypeError: jQuery(...).show(...).nivoSlider is not a function
    [Break On This Error] 	
    
    afterLoad: function(){}		});
    
    rrdesign.nl (line 162)
    
    TypeError: a.slideshow is not a function
    [Break On This Error] 	
    
    ...en"),d=a.find(".wk-slideset").css("visibility","hidden"),e=d.find("ul.set > li")...
    I also don't know why he is searching for a notifications.css as i don't know where that line is coming from.

  • #4
    Senior Coder DanInMa's Avatar
    Join Date
    Nov 2010
    Location
    Salem,Ma
    Posts
    1,577
    Thanks
    13
    Thanked 248 Times in 248 Posts
    you are using mootools and jquery on the same page, this can cause conflicts. read this sticky for more : Scripts are incompatible/don’t work when used together

  • Users who have thanked DanInMa for this post:

    rrdesign (12-05-2012)

  • #5
    New Coder
    Join Date
    Sep 2011
    Posts
    25
    Thanks
    7
    Thanked 0 Times in 0 Posts
    Thank you for that, removed some stuff have to find a way to make it work.

    Solved:
    had to remove:

    Code:
    <script type="text/javascript" src="<?php echo $this->baseurl ?>/templates/<?php echo $this->template ?>/includes/jquery.js"></script>
    From the index2.php now everything is working.
    Last edited by rrdesign; 12-05-2012 at 09:47 PM.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •