Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Sep 2011
    Posts
    57
    Thanks
    8
    Thanked 0 Times in 0 Posts

    IE ruining my site with "pageTracker" undefined

    I've been testing my site in firefox and safari and everything was a OK. Now IE is telling me that "pagetracker" is undefined and its not taking me to the other links on my site. Also the content on the first page is not showing up in IE.

    jonathaneiger.com

  • #2
    Senior Coder DanInMa's Avatar
    Join Date
    Nov 2010
    Location
    Salem,Ma
    Posts
    1,577
    Thanks
    13
    Thanked 248 Times in 248 Posts
    did you recently update your google analytics source code by chance?

  • #3
    Senior Coder DanInMa's Avatar
    Join Date
    Nov 2010
    Location
    Salem,Ma
    Posts
    1,577
    Thanks
    13
    Thanked 248 Times in 248 Posts
    I suspect you did. this appears to be the solution: http://stackoverflow.com/questions/3...is-not-defined

    Code:
    	<div id="h_menu">
    		<ul id="menu_new">
    			<li><a href="#home" class="navi_home" onClick="_gaq.push(['_trackEvent', 'Main', 'Home', 'Home']);">home</a></li>
    			<li><a href="#portfolio" class="navi_portfolio" onClick="_gaq.push(['_trackEvent', 'Main', 'Portfolio', 'Portfolio']);">about</a></li>
    
    			<li><a href="#services" class="navi_services" onClick="_gaq.push(['_trackEvent', 'Main', 'Services', 'Services']);">services</a></li>
    			<li><a href="#about_us" class="navi_about" onClick="_gaq.push(['_trackEvent', 'Main', 'About', 'About']);">portfolio</a></li>
    			<li><a href="#contact_us" class="navi_contact" onClick="_gaq.push(['_trackEvent', 'Main', 'Contact', 'Contact']);">contact</a></li>
    		</ul>
    	</div>

  • #4
    New Coder
    Join Date
    Sep 2011
    Posts
    57
    Thanks
    8
    Thanked 0 Times in 0 Posts
    Thanks! It solved the error problems it was giving me but it still doesnt go to the other pages of the site. It working in safari and firefox though

  • #5
    Senior Coder DanInMa's Avatar
    Join Date
    Nov 2010
    Location
    Salem,Ma
    Posts
    1,577
    Thanks
    13
    Thanked 248 Times in 248 Posts
    if you applied the changes i suggested, they are not showing on your live site.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •