Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    Regular Coder
    Join Date
    Apr 2010
    Posts
    207
    Thanks
    30
    Thanked 0 Times in 0 Posts

    Javascript slider messing up the rest of the site....need help!

    OK, a friend and I have been working on implementing the javascript slider you see in the header of my website http://www.billboardfamily.com (hover over the facebook icon under the search area).

    For some reason, this is causing a lot of the other items on the site to stop functioning all together. Can anyone help me figure out how to fix this?

    NOTE: Running Wordpress

    Here are some of the problems:

    1) http://billboardfamily.com/videos/ The thumbnail videos do not work when you click them
    2) http://billboardfamily.com/the-process/ All 4 slides are on the page, but the slider is not working at all.
    3) http://billboardfamily.com/contact-us/ The contact forms I have running are not working correctly, and the styling is no longer correct.
    Website: www.billboardfamily.com
    Twitter: www.twitter.com/billboardfamily
    Facebook Fan Page: www.facebook.com/BillboardFamily
    Facebook (Carl): www.facebook.com/CarlMartin.BillboardFamily (admin note: sig should be <=4 lines)

  • #2
    New to the CF scene
    Join Date
    Aug 2006
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I'm not exactly sure to what you're referring as far as the JavaScript slider in your header goes. I do see a lot of JavaScript files called in your <head> code, but there is enough script there that I'd rather not browse through it to find what's faulty. Also, I don't see any explicit calls to your script: on-event handlers (onLoad, onClick, onMouseover, onChange, etc.) or the like.

    I looked at the 3 issues you listed below and didn't see any problems. The videos load (but don't autoplay — did you want them to?); the slides work when I click the vertical "tabs"; the styling on the /contact-us/ page seems OK to me at first glance — how should it be differently styled?

    Can you indicate where specifically the trouble is (e.g., indicate a function that is failing or specify an element that has its alignment or functionality off)? If possible, please include a code snippet of both the JavaScript and associated HTML where the problem lies. (For instance, if an element should call a JavaScript function, include the function that isn't working and the place in your HTML where the function is called.)

    (By-the-by, I did notice you have no href attribute in your link for the Facebook icon.)

    Oneilius
    Last edited by Oneilius; 08-25-2010 at 11:35 PM.

  • #3
    Regular Coder
    Join Date
    Apr 2010
    Posts
    207
    Thanks
    30
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Oneilius View Post
    I'm not exactly sure to what you're referring as far as the JavaScript slider in your header goes. I do see a lot of JavaScript files called in your <head> code, but there is enough script there that I'd rather not browse through it to find what's faulty. Also, I don't see any explicit calls to your script: on-event handlers (onLoad, onClick, onMouseover, onChange, etc.) or the like.

    I looked at the 3 issues you listed below and didn't see any problems. The videos load (but don't autoplay — did you want them to?); the slides work when I click the vertical "tabs"; the styling on the /contact-us/ page seems OK to me at first glance — how should it be differently styled?

    Can you indicate where specifically the trouble is (e.g., indicate a function that is failing or specify an element that has its alignment or functionality off)? If possible, please include a code snippet of both the JavaScript and associated HTML where the problem lies. (For instance, if an element should call a JavaScript function, include the function that isn't working and the place in your HTML where the function is called.)

    (By-the-by, I did notice you have no href attribute in your link for the Facebook icon.)

    Oneilius
    I completely removed the sliding menu so I could work on the rest of the site without it being messed up. Once the rest of the site is done, I will try another go at the sliding menu, and if it still is problematic....I will post on this forum. Thanks
    Website: www.billboardfamily.com
    Twitter: www.twitter.com/billboardfamily
    Facebook Fan Page: www.facebook.com/BillboardFamily
    Facebook (Carl): www.facebook.com/CarlMartin.BillboardFamily (admin note: sig should be <=4 lines)


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •