Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 12 of 12
  1. #1
    New to the CF scene
    Join Date
    Apr 2003
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    slideshow image links in new window?

    I am using this scritp:

    http://javascriptkit.com/script/script2/3slide.shtml

    Is there a way to open the image links in a new window (target=_blank)? I don't see any actual href's in the code to add to.

    Thanks

    Eric

  • #2
    Senior Coder
    Join Date
    Aug 2002
    Posts
    3,467
    Thanks
    0
    Thanked 0 Times in 0 Posts
    you can use my slideshow

    http://www.peterbailey.net/dhtml/ss_with_links.htm

    It's very flexible
    My Site | fValidate | My Brainbench | MSDN | Gecko | xBrowser DOM | PHP | Ars | PVP
    “Minds are like parachutes. They don't work unless they are open”
    “Maturity is simply knowing when to not be immature”

  • #3
    New to the CF scene
    Join Date
    Apr 2003
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks, that works great.

    How do I get it to stop playing automatically, and turn random off?

    Eric

  • #4
    Senior Coder
    Join Date
    Aug 2002
    Posts
    3,467
    Thanks
    0
    Thanked 0 Times in 0 Posts
    remove these two commands

    ss1.go( 'random' );
    ss1.play( 3000 );
    My Site | fValidate | My Brainbench | MSDN | Gecko | xBrowser DOM | PHP | Ars | PVP
    “Minds are like parachutes. They don't work unless they are open”
    “Maturity is simply knowing when to not be immature”

  • #5
    New to the CF scene
    Join Date
    Apr 2003
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    When I do that I can't manually get the slideshow to run in automatic mode. when I push "play" it advances to the second slide and stops, and does not continue to the next slide. I want the functionality to work, but I don't want it starting on it's own as a default. I want the default to be in "stop" mode.

    Eric

  • #6
    Senior Coder
    Join Date
    Aug 2002
    Posts
    3,467
    Thanks
    0
    Thanked 0 Times in 0 Posts
    sorry, my fault. Forgot something. If you don't use play, you have to set a delay manually

    Use the below in the place of the two lines I told you to remove

    ssObj.setDelay( delay );

    Where ssObj is youre slideshow, and delay is the desired delay in milliseconds.
    My Site | fValidate | My Brainbench | MSDN | Gecko | xBrowser DOM | PHP | Ars | PVP
    “Minds are like parachutes. They don't work unless they are open”
    “Maturity is simply knowing when to not be immature”

  • #7
    New to the CF scene
    Join Date
    Apr 2003
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Works perfect! Thanks!

    Eric

  • #8
    New to the CF scene
    Join Date
    Apr 2003
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I just noticed that the images don't show up on Netscape 4.7, or IE 5.1 for Mac. they only work on PC's.

    Any idea if there is a tweak to make it work for Mac?

    Thanks,
    Eric

  • #9
    Senior Coder
    Join Date
    Aug 2002
    Posts
    3,467
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hmm. Yes, but I'll have to check my references, as I don't have a Mac to test on.

    Got any helpful error information?
    My Site | fValidate | My Brainbench | MSDN | Gecko | xBrowser DOM | PHP | Ars | PVP
    “Minds are like parachutes. They don't work unless they are open”
    “Maturity is simply knowing when to not be immature”

  • #10
    New to the CF scene
    Join Date
    Apr 2003
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It just shows the broken image icon where the slideshow pistures should be. The link works under the broken image though.

    Also the controls in the DIV tag don't show up.

    Eric

  • #11
    Senior Coder
    Join Date
    Aug 2002
    Posts
    3,467
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Oh ya, I know why the controls don't work. IE-mac doesn't support attachEvent() or addEventListener. However, I found a wrapper for this at DHTML kitchen that I've been meaning to apply.

    Do you have a time-constrait with this project?
    My Site | fValidate | My Brainbench | MSDN | Gecko | xBrowser DOM | PHP | Ars | PVP
    “Minds are like parachutes. They don't work unless they are open”
    “Maturity is simply knowing when to not be immature”

  • #12
    New to the CF scene
    Join Date
    Apr 2003
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It's something I am trying to get wrapped up in the next 2 weeks. whatever you can do, I apperciate your help.

    Eric


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •