Hi,


I have a simple Flash movie that I want to display in my html page. I published the movie from Flash using FSCommand option. This option placed code in a html file that is called when a FSCommand is issued in Flash.

This works fine in IE, but the function doesn't get called at all in Netscape or Mozilla.

What's wrong?


Code:



<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
<title>home3</title>
<meta name="vs_defaultClientScript" content="JavaScript">
<meta name="vs_targetSchema" content="http://schemas.microsoft.com/intellisense/ie5">
<meta name="GENERATOR" content="Microsoft Visual Studio.NET 7.0">
<meta name="ProgId" content="VisualStudio.HTML">
<meta name="Originator" content="Microsoft Visual Studio.NET 7.0">

<script language="javascript" src="JavascriptFile.js" type="text/javascript"></script>
</head>
<body MS_POSITIONING="GridLayout" bgcolor="#3399CC">
<script LANGUAGE="JavaScript">
<!--
var InternetExplorer = navigator.appName.indexOf("Microsoft") != -1;
// Handle all the the FSCommand messages in a Flash movie
function Menu1_DoFSCommand(command, args) {
alert('ok')
var Menu1Obj = InternetExplorer ? Menu1 : document.Menu1;
if (command=='Goto'&&args!='')
{
window.location=args;
}
else if (command=='DisplayHelp'&&args!='')
{
//alert(command+' , '+args)
var zDisplay = args=='true'?'visible':'hidden'
var zItem = MM_findObj('DisplayHelp');
if (zItem){zItem.style.visibility=zDisplay;}

}
}
/*
// Hook for Internet Explorer
if (navigator.appName && navigator.appName.indexOf("Microsoft") != -1 &&
navigator.userAgent.indexOf("Windows") != -1 && navigator.userAgent.indexOf("Windows 3.1") == -1) {
document.write('<SCRIPT LANGUAGE=VBScript\> \n');
document.write('on error resume next \n');
document.write('Sub Menu1_FSCommand(ByVal command, ByVal args)\n');
document.write(' call Menu1_DoFSCommand(command, args)\n');
document.write('end sub\n');
document.write('</SCRIPT\> \n');
}
*/

//-->
</SCRIPT>
<!-- URL's used in the movie-->
<!-- text used in the movie-->
<object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0"
ID="Menu1" WIDTH="300" HEIGHT="160" ALIGN="top" VIEWASTEXT>
<param NAME=movie VALUE="Menu1.swf">

<param NAME=quality VALUE=high>
<param NAME=bgcolor VALUE=#3399CC>
<embed src="Menu1.swf" quality=high bgcolor=#3399CC WIDTH="300" HEIGHT="160" swLiveConnect=true ID="Menu1" NAME="Menu1" ALIGN="top"
TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></embed>

</object>
<!-- Display Help
-->
<div style="FONT-SIZE: 10pt; VISIBILITY: hidden; BACKGROUND-COLOR: aqua; TEXT-ALIGN: center" id="DisplayHelp">Help...</div>
</body>
</html>