Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts

    Why this swf won't appear when others do?

    Hello

    Got one Flash file to work/show on our web site, but when I go to place another flash file, on a different page but using the same js code (with of course the different flash file's unique name and details), the file doesn't appear at all...the swf (348k) and its html from Flash are both uploaded to server, etc...can't figure this out after about 1/2 hour...using css to position it and asp.net. Using DW and Flash 8 to author.

    here's the js code:

    ============

    <p><span class="FlipBookAlign">
    <script type="text/javascript">
    AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0','name','FlipBook','w idth','450','height','380','id','FlipBook','title' ,'FlipBook','src','/Images/FlipBook','loop','true','quality','high','pluginsp age','http://www.macromedia.com/go/getflashplayer','play','true','movie','/Images/FlipBook' ); //end AC code
    </script><noscript><object
    classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000"
    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0"
    name="FlipBook" width="450" height="380" id="FlipBook" title="FlipBook">
    <param name="movie" value="/Images/FlipBook.swf" />
    <param name="quality" value="high" /><param name="LOOP" value="false"
    /><param name="PLAY" value="true" />
    <embed src="/Images/FlipBook.swf" width="450" height="380" loop="False"
    quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer"
    type="application/x-shockwave-flash" name="FlipBook" play="true"></embed>
    </object></noscript></span></p>

    ========

    Here's the css

    ===========

    #copy .FlipBookAlign {
    display:block;
    position: fixed;
    visibility: visible;
    }

    ============

    Thanks for any help

    KB

  • #2
    Regular Coder BWiz's Avatar
    Join Date
    Mar 2006
    Location
    Sol System
    Posts
    471
    Thanks
    7
    Thanked 21 Times in 21 Posts
    Have you made sure that the JavaScript URL is relative to that of the page? Did you change it when you pasted it from the previous page to the next. I'm not sure what "file's unique name and details" means.
    BWiz :: Happy Coding!
    2006
    2007 2008 2009
    2010 2011
    Irrational numbers make no sense.

  • #3
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts
    Thanks for your reply - can you believe it, I searched for what could possibly be the problem and I found that I hadn't put this at the top of the page...

    <script src="../Scripts/AC_RunActiveContent.js" type="text/javascript"></script>

    ugh!


    KB

    P.S. Now it works...


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •