Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 8 of 8
  1. #1
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts

    Lightbox problem only on ONE browser - fix?

    Hello

    If you go to http://www.enhancedwireless.net/Tech...TS/P240A.shtml and click on either the PARROT 240B link or the image of the blue device link, you'll get the lightbox effect - very nice, but in only Firefox - latest for mac - when you try to close it by clicking the "x" lower right corner, upon click it brings up a corrupted scroll bar/box around the "x" and only if you click it twice will it close.

    How to fix?

    Thanks much

    KB

  • #2
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts
    Any thoughts at all?

    KB

  • #3
    New Coder
    Join Date
    Sep 2006
    Posts
    24
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Works fine in my Safari browser on my PC.

    yes, I said it...

    http://www.apple.com/pr/library/2007/06/11safari.html

  • #4
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts
    Yes, I know, thanks for reply - but the problem is only on FireFox on mac - really need a fix for this.

    KB

  • #5
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Try removing this from #imageDataContainer
    Code:
    overflow: auto;
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #6
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts
    Well - I think you've at least narrowed it down to the right area - I change overflow: auto to overflow: none and the white bottom border of the lightbox image (very neccessary because that's where the text goes) is removed on all browsers, no good...tried completely deleting the overflow line from the css and the exact same issue happens as above, no white border - though it does now close in FF with just one click of the "x" button.

    Almost there it seems - thoughts?

    KB

  • #7
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    overflow:none; isn't valid. Try overflow:hidden; instead.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #8
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts
    Excellent - using "hidden" it now works in all browsers! Thanks so much...now if I can only get this small issue sorted out, I'd be set.

    http://www.codingforums.com/showthre...690#post575690

    Thanks

    KB


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •