Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New Coder
    Join Date
    Oct 2006
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts

    weird problem - works in FF, but no in IE

    I am using BoxOver script (http://boxover.swazz.org) and have done a few things on my own to make it work like I want it to.

    The way this script works is it automatically takes the title tag from a tag and then converts the internal parts of this to a tooltip. I have edited the code so instead of just inputting information into the title tag I have it go out to an XML file and pull the definition of the word and then return that information to the title so it will take that definition and put it into the tooltip. Here is my code:
    Code:
    //the span function
    <span onMouseOver="hover(this, true);" onMouseOut="hover(firstCap(this, false));" class="word" title="">word</span>
    
    //within the hover function
    oThis.title = "header=[" + tmp_head + "] body=[" + tmp_body + "] cssbody=[body1] cssheader=[head1] fade=[on] fadespeed=[.05] fixedrely=[-1] fixedrelx=[-3]";
    Now I know I dont have any problem getting the information from the XML file for one very interesting reason, which has stumped me. When I hover over each of the spans it does a standard tooltip when you hover over something with a title tag, and has the information "header=[correct word] body=[correct definition]... etc..."

    This tells me that it is going out, getting the data just fine and also returning this information to the title tag of the span, otherwise it would not create that tooltip with that information in it.

    To ensure the script works fine in IE and via the way I want it to, i have inserted a span as follows into the code for testing:
    Code:
    <span title="header=[Title] body=[Body] cssbody=[body1] cssheader=[head1] fade=[on] fadespeed=[.05] fixedrely=[-1] fixedrelx=[-3]">test</span>
    This code renders the exact code I want and pops up the tooltip just the way I want.

    This code also works in firefox and returns the popup I want upon hover over on both the static code (1 above), as well as using the script to input the information.

    So I dont understand why it would output this information to the title field, but not create the popup like it does in firefox. Any help would be great.

  • #2
    New Coder
    Join Date
    Oct 2006
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts
    well "thanks" mike...
    Last edited by mynameisdave145; 12-20-2006 at 09:17 PM.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •