Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 8 of 8
  1. #1
    New Coder
    Join Date
    May 2012
    Posts
    57
    Thanks
    12
    Thanked 0 Times in 0 Posts

    Can't get jQuery image gallery working

    I found a free source code for an image gallery. But I cant seem to get it working on a website Im trying to put together.

    There is some error in my code when Im trying to implement it to my site, because instead of images popping out as a slider in the middle of the page the images open up in a separate window when I click on them...

    the website is here: http://tihemetsamoto.ee/uus2013/#projects

    this is probably some stupid mistake I can't figure out, can someone help please?

  • #2
    Supreme Master coder! Old Pedant's Avatar
    Join Date
    Feb 2009
    Posts
    25,023
    Thanks
    75
    Thanked 4,323 Times in 4,289 Posts
    Way too many errors to even begin to guess where you went wrong.

    Chrome reports all these errors, *JUST* from LOADING your page, never mind anything else:
    Failed to load resource: the server responded with a status of 404 (Not Found) http://tihemetsamoto.ee/uus2013/demo...r-2.6.2.min.js

    Uncaught TypeError: Object [object Object] has no method 'lightBox' tihemetsamoto.ee:92

    Invalid 'X-Frame-Options' header encountered when loading 'https://maps.google.com/maps/ms?msa=0&msid=211514500413230185852.0004c4e025…&ie=UTF8&t=m&ll=58.158931,24.983597&spn=0.04347,0.109 863&z=13&output=embed': 'ALLOWALL' is not a recognized directive. The header will be ignored. about:blank:1

    Failed to load resource: the server responded with a status of 404 (Not Found) http://tihemetsamoto.ee/uus2013/font...ne-Regular.svg

    Failed to load resource: the server responded with a status of 404 (Not Found) http://tihemetsamoto.ee/uus2013/font...e-Regular.woff
    8

    Unsafe JavaScript attempt to access frame with URL http://tihemetsamoto.ee/uus2013/#projects from frame with URL https://maps.google.com/maps/ms?msa=...3&output=embed. The frame requesting access has a protocol of 'https', the frame being accessed has a protocol of 'http'. Protocols must match.

    Failed to load resource: the server responded with a status of 404 (Not Found) http://tihemetsamoto.ee/uus2013/images/blog.jpg

    78 (means it found 78 occurrences of this error)
    Unsafe JavaScript attempt to access frame with URL http://tihemetsamoto.ee/uus2013/#projects from frame with URL https://maps.google.com/maps/ms?msa=...3&output=embed. The frame requesting access has a protocol of 'https', the frame being accessed has a protocol of 'http'. Protocols must match.
    An optimist sees the glass as half full.
    A pessimist sees the glass as half empty.
    A realist drinks it no matter how much there is.

  • #3
    New Coder
    Join Date
    May 2012
    Posts
    57
    Thanks
    12
    Thanked 0 Times in 0 Posts
    I apologize, I had some unneccessary rubbish there. I think I cleaned it up as far as errors go.

    Still can't figure out why the image gallery is not acting right.
    On this webpage http://leandrovieira.com/projects/jquery/lightbox/ under 'Example.' you can see how the lightbox should work. But all I get is images opening in new window http://tihemetsamoto.ee/uus2013/#projects

  • #4
    Senior Coder xelawho's Avatar
    Join Date
    Nov 2010
    Posts
    2,882
    Thanks
    56
    Thanked 539 Times in 536 Posts
    Uncaught TypeError: Object [object Object] has no method 'lightBox'
    that can't be good...

  • #5
    New Coder
    Join Date
    May 2012
    Posts
    57
    Thanks
    12
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by xelawho View Post
    that can't be good...
    I don't know what to do about it...

    Can it be that for some reason it is not connecting to the javascript files that make the lightbox work? And what that reason might be...

  • #6
    Senior Coder xelawho's Avatar
    Join Date
    Nov 2010
    Posts
    2,882
    Thanks
    56
    Thanked 539 Times in 536 Posts
    you have 7 external scripts (including 2 versions of jQuery), as well as inline javascript . try simplifying your code until you find out what the problem is

  • Users who have thanked xelawho for this post:

    krispol (04-28-2013)

  • #7
    New Coder
    Join Date
    May 2012
    Posts
    57
    Thanks
    12
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by xelawho View Post
    you have 7 external scripts (including 2 versions of jQuery), as well as inline javascript . try simplifying your code until you find out what the problem is
    ok, thank you, I'll give it a go

  • #8
    New Coder
    Join Date
    May 2012
    Posts
    57
    Thanks
    12
    Thanked 0 Times in 0 Posts
    Thank you all for pushing me to the right direction, got it working!


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •