Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Oct 2012
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Simple auto slideshow flips out for 10 seconds

    Hi all, I'm an aspiring pre-novice in CSS and JS, so I apologize in advance. This might be a simple issue or complex, I haven't a clue.

    go to www.michaelsiemsen.com/new in Firefox, Safari, or IE9 and the big banner image flips out for 10 seconds before commencing as it should. The first image is supposed to be handprint, then book, then giant author mugshot. The creators of this site have no clue why it won't work, nor do they care as this banner photo is supposed to be static and I have apparently "ruined" it by attempting to animate it. Ah well...

    Here is the code that makes the images cycle:

    HTML:
    Code:
     <div id="slideshow">
                        <div>
                     <img src="images/img1.jpg">
                    	</div>
                        <div>
                     <img src="images/img2.jpg">
                    	</div>
                        <div>
                     <img src="images/img3.jpg">
                    	</div>
    			</div>

    CSS:
    Code:
     #slideshow {
    	margin: 1px 0 6px auto;
    	position: relative;
    	width: 1172px;
    	height: 524px;
    	padding: 0;
    }
    
    #slideshow > div {
    	position: absolute;
    	top: 1px;
    	left: 1px;
    	right: 1px;
    	bottom: 1px
    }
    JS:
    Code:
    $("#slideshow > div:gt(0)").hide();
    
    setInterval(function() { 
      $('#slideshow > div:first')
        .fadeOut(1000)
        .next()
        .fadeIn(1000)
        .end()
        .appendTo('#slideshow');
    },  4000);
    Thanks in advance to anyone that can help! And again, sorry if I am dumb!

  • #2
    New to the CF scene
    Join Date
    Oct 2012
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Not so simple I guess?

    No takers? Did I leave out important information? Do I need to pay someone to fix this? If so, who?

  • #3
    Senior Coder
    Join Date
    Dec 2010
    Posts
    2,396
    Thanks
    12
    Thanked 569 Times in 562 Posts
    The URL has a 404

  • Users who have thanked devnull69 for this post:

    jestermeister (10-06-2012)

  • #4
    New to the CF scene
    Join Date
    Oct 2012
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Sorry, It didn't seem like anyone was seeing my post so I went elsewhere and it's all fixed now. Thanks for checking it, though!

  • #5
    Senior Coder xelawho's Avatar
    Join Date
    Nov 2010
    Posts
    2,916
    Thanks
    56
    Thanked 545 Times in 542 Posts
    would you mind posting the solution? I have seen questions about the same problem with the slideshow script a couple of times, but I have never seen anybody with a way to fix it.

  • Users who have thanked xelawho for this post:

    jestermeister (10-08-2012)

  • #6
    New to the CF scene
    Join Date
    Oct 2012
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Sure, sorry... in the js file, the script must be bracketed by the following code:

    Code:
    $(document).ready(function(){
    
    $(javascript code here);
    
    });
    Hope that helps!


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •