Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exclamation comment system: not working in IE and Firefox!!!

    Dear all,

    I am very very new to javascript, i just learn from the tutorial and try to add validation to it, but it can't run in IE and firefox, but running in safari.

    here is the index.php
    ...

    addcomment.php
    ...

    <<< the code is deleted by erica>>>
    Last edited by hiuyu; 07-03-2010 at 08:48 AM. Reason: finished the study!! thank you

  • #2
    UE Antagonizer Fumigator's Avatar
    Join Date
    Dec 2005
    Location
    Utah, USA, Northwestern hemisphere, Earth, Solar System, Milky Way Galaxy, Alpha Quadrant
    Posts
    7,691
    Thanks
    42
    Thanked 637 Times in 625 Posts
    What errors are you seeing? How is it "not working"? Does your query call return true or false, and if it returns false, are you handling that? (the answer is no on that one) And are you also aware that you can't rely on client validation alone? You also need server-side validation; anyone can send a post request to your server script and completely bypass your validation.

  • #3
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    This is my example link:
    the link is deleted.
    Last edited by hiuyu; 07-03-2010 at 08:46 AM. Reason: deleted example, link will be expired

  • #4
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Is relate to the setting of apache: mime ??

  • #5
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I use my own server!!!

  • #6
    UE Antagonizer Fumigator's Avatar
    Join Date
    Dec 2005
    Location
    Utah, USA, Northwestern hemisphere, Earth, Solar System, Milky Way Galaxy, Alpha Quadrant
    Posts
    7,691
    Thanks
    42
    Thanked 637 Times in 625 Posts
    Install Firebug and check out the error on your ajax call.

  • #7
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Fumigator View Post
    Install Firebug and check out the error on your ajax call.
    It really help.
    I have solve the problem.

    Thank you.


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •