Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    Regular Coder
    Join Date
    Dec 2009
    Posts
    115
    Thanks
    2
    Thanked 10 Times in 10 Posts

    Trouble With LightBox of All Things...

    Here's the entire bit of code I have on test page. For whatever reason, lightBox seems to come up, but the initial overlay div (it's a very dark grey for me) ends up being over 300px tall.

    PHP Code:
    <html>

    <
    head>
    <
    script type="text/javascript" src="/js/jquery.js"></script>
    <script type="text/javascript" src="/js/lightBox/js/lightbox.js"></script>

    <script type="text/javascript">
        $(document).ready(function(){
            $("#gallery a").lightBox();
        });
    </script>

    </head>

    <body>
        <div id="gallery">
            <a href="/images/newLogo.png" title="My new Logo!">lightBox</a>
        </div>
    </body>

    </html> 
    I can't believe all of the sudden I'm having so much trouble. Google Chrome's Javascript Console tells me "Resource interpreted as image but transferred with MIME type text/html." Firebug doesn't seem to be really helping much.

    Any ideas?

  • #2
    Regular Coder
    Join Date
    Dec 2009
    Posts
    115
    Thanks
    2
    Thanked 10 Times in 10 Posts
    I got the lightBox working. I forgot to include the lightbox CSS file.

    Now my only problem is the MIME types for the images for the buttons. They're not working. I use Gnome as my FTP program and it's never had a problem transferring images correctly in binary mode.

    I even made the images new in GIMP, saved them as GIFs, and check the Image Properties in GIMP, and it says URI instead of GIF image.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •