Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3

Thread: help!

  1. #1
    Regular Coder
    Join Date
    Aug 2008
    Posts
    105
    Thanks
    9
    Thanked 0 Times in 0 Posts

    Smile help!

    The following code is driving me MAD...

    I just want the h5 to be clickable, and when you click it it will show the company details, when you click it again it hides them! I'm seriously going crazy because the function works in firebug but not when I upload it to the site!!!!! ARRGH!!! Why would it do this???

    Code:
    jQuery(document).ready(function (){
    	jQuery("#meme").click(function(){
    			$(this).parents(".specialistContainer").find(".twistyContent").toggle();
    			$(this).find("span").remove();
    			$(this).prepend("<span>-</span>");
    		}); 
    });
    
    
    ...
    
    <div style="display:none;">
        <div class="specialistContainer">
            <h5>Company name</h5>
            <div class="twistyContent">
                123 street
                <br/>
                Lotherton Way
                <br/>
                Garforth
                <br/>
                Leeds
                <br/>
                LS25 4GB
                <br/>
                0113 287 2222
            </div>
            <a href="mailto:companyemail" style="color: #000;font-weight: bold;">info@companyemail.com</a>
            <br/>
            <a href="http://www.companyurl.com" target="_blank" alt="Paul Turner Signwriters" title="Paul Turner Signwriters" style="color: #000;">www.companyurl.com</a>
        </div>
    </div>
    What am I doing wrong!??!

  • #2
    UE Antagonizer Fumigator's Avatar
    Join Date
    Dec 2005
    Location
    Utah, USA, Northwestern hemisphere, Earth, Solar System, Milky Way Galaxy, Alpha Quadrant
    Posts
    7,691
    Thanks
    42
    Thanked 637 Times in 625 Posts

  • #3
    Regular Coder
    Join Date
    Aug 2008
    Posts
    105
    Thanks
    9
    Thanked 0 Times in 0 Posts
    Ok to anyone seeking the answer:

    My problem was different. I found out from a little more investigation the page is dynamically copying the HTML from a hidden portion of the page, & inserting it as new HTML of a newly created element. That is why the event handler's were not being attached to the proper element and thus not registering clicks.

    the code above needs some minor tweaks but it works if youre using those names


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •