Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Aug 2009
    Location
    Portland, OR
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Container plugin affecting list type

    I'm working on a site that uses the (mb)ContainersPlus plugin. In the "photographs" div container, I'm attempting to add a slider plugin to display the photo thumbnails. I've tried both the "better coda slider" and Easy Slider. The gist of those sliders is that you list items inline, and the first one is displayed while all the others are hidden off to the side - and when you call the next one, it slides over horizontally and is displayed.

    My problem is that my list items are not inline. They are stacked on top of each other. Despite doing all I can think of to specify in the style that they should be type:none and should be inline, they just won't agree to that.

    What I've observed is that the ul's width should be adjusting in size to fit all the items horizontally, but there's something going on that's keeping the width at 0px. At this point, it seems like the container plugin has to be affecting things somehow. But it's not, as far as I can tell, in the container's css. So it must be in the js file! However, I'm not skilled enough to parse the js file. The simplest culprit would be the js calls (the order of them, maybe). I just don't know enough about calls to figure out how they would be conflicting.

    At this point I'm thinking of just dumping mbcontainersplus for something else. I am barely using any of its features - I mostly picked it for the rounded corners, and because it doesn't do any snazzy loading stuff.

    Any advice would be appreciated. It seems like this should be fairly simple to fix. And I hope my description made sense! I feel really dumb for not figuring this out by now. It's extremely frustrating.
    Last edited by ganatronic; 08-20-2009 at 09:14 PM.

  • #2
    New to the CF scene
    Join Date
    Aug 2009
    Location
    Portland, OR
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    So, does any know why the ul's style on this page that uses the easy slider would inherit the total width of all the li's:

    Code:
    element.style {
    margin-left:-696px;
    width:4872px;
    }
    (note: that style is not in the css file - I obtained that info from firebug)

    while on my site the ul is not inheriting those dimensions:

    Code:
    element.style {
    width:0;
    }
    It's almost as if the ul tag is not working. (Think this thread should be moved to a different subforum?)

  • #3
    New to the CF scene
    Join Date
    Aug 2009
    Location
    Portland, OR
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Okay, I've narrowed down the issue greatly, and as far as I can tell have it isolated. However, I still can't fix it.

    In the working version, the container with the slider is not hidden - it's always there, and it works. In the broken version, the container is hidden, and shown with an onlick. That's the only difference between the two versions.

    So when the container is shown via click, something breaks. That's the problem! In firebug, the ul is grayed, for some reason...

    Any input?
    Last edited by ganatronic; 08-25-2009 at 07:18 PM.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •