Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    Nov 2013
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Post Embed tag is not working with Mozilla Firefox 23, 24 and 25

    Requirement:
    While loading the java applet on a page, if the user system do not have plugin loaded then our code should redirect the user to get Java 1.6 plugin.

    At present I am using below two URL for automatically JRE6 download

    • IE : https://java.sun.com/update/1.6.0/ji...rsion=1,6,0,31 [When user tries to access the applet page from IE browser then he/she is getting pop-up message for JRE6 installation, provided that the user system don’t have any JRE installed]. This scenario is working IE8,9,10

    • Mozilla family : https://javadl.sun.com/webapps/downl...BundleId=60336


    Code:
    <script language="javascript" >
    <OBJECT classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93" name="OrderApplet"';
    WIDTH = 775 HEIGHT = 600  
    codebase="https:\/\/java.sun.com\/update\/1.6.0\/jinstall-6-windows-i586.cab">';
    …………
    <PARAM NAME = "type"  VALUE="application\/x-java-applet;version=1.6.0_31">';
    <PARAM NAME = "scriptable"   VALUE  = "true" >';
    ………
    <COMMENT>';
    <EMBED type="application\/x-java-applet;version=1.6"  
    ………
    pluginspage="https:\/\/javadl.sun.com\/webapps\/download\/AutoDL?BundleId=60336">
    <NOEMBED>
    <\/COMMENT>;
    <\/NOEMBED><\/EMBED>;
    <\/OBJECT>;
    </script>
    User is getting pop-up message for JRE6 installation with browser IE8, 9, and 10 and also with Mozilla Firefox 22, but it’s failing with latest version of Mozilla Firefox23,24 and 25.

    I have gone through so many sites but could find any reason for this behavior.

    I have provided JRE6 32-bit version download URL, here I don’t think so I’m doing any version incompatibility because both the JRE6 and Mozilla Firefox are 32-bit version. And 64 bit Firefox version is not available for windows.


    I’m not sure why the code is working with Firefox 22 and its lower version but doesn’t work with higher version than firefox22….like 23,24,25

    Can anyone help to sort out this issue?

    Thanks,
    Sumit

  • #2
    Master Coder felgall's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Posts
    6,618
    Thanks
    0
    Thanked 645 Times in 635 Posts
    All current browsers including IE7 can use the object tag (as long as you omit the non-standard classid attribute). The only browser to require the use of the embed tag is Netscape 4.
    Stephen
    Learn Modern JavaScript - http://javascriptexample.net/
    Helping others to solve their computer problem at http://www.felgall.com/

    Don't forget to start your JavaScript code with "use strict"; which makes it easier to find errors in your code.

  • Users who have thanked felgall for this post:

    sumitgu (12-04-2013)

  • #3
    New to the CF scene
    Join Date
    Nov 2013
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Yes, correct.
    But I am wondering why Mozilla Firefox 23,24 and 25 doesn’t download the JRE based on the Url which I have mentioned in the ‘pluginspage’ tag. But the same works with Firefox version 22 and lesser.

    I have posed the same issue with Mozilla forum and they suggested that Firefox 23 brought in a new Simplified interface for notifications of plugin installation.

    So, I’m confuse what next step should I take to make this work.
    Any suggestion?

  • #4
    New to the CF scene
    Join Date
    Nov 2013
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Any update please?


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •