Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Oct 2002
    Location
    Ireland
    Posts
    39
    Thanks
    0
    Thanked 0 Times in 0 Posts

    css borders on <tr> tags

    Hi I am trying to put a border on a <tr> tag as follows

    border:1px solid #417067;

    The border won't appear is this incorrect??

    Thnaks, Kathryn

  • #2
    Regular Coder
    Join Date
    Jun 2002
    Location
    NL
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Works for me...

    <html>
    <head>
    <title></title>
    </head>
    <body>
    <table>
    <tr style="border:1px solid #417067;">
    <td>cell</td>
    <td>cell</td></tr>
    <tr>
    <td colspan="2">cell</td></tr></table>
    </body>
    </html>

  • #3
    New Coder
    Join Date
    Oct 2002
    Location
    Atlanta
    Posts
    28
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I copied this code example into a HTML document and ran it under both IE 6.0 and Mozilla; neither displays a border on that row ...

    Not sure what browser you're using that it works with ... but I have to back-up what the original poster said ... it's not functioning.

  • #4
    Regular Coder
    Join Date
    Jun 2002
    Location
    NL
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Dhtroy, I was using IE 5.1 on Mac. But actually, I've previewed that code in Moz and Opera now and no border was showing. So.. I think I have found a bug

    You have to set the borders on the cells, kathryn. A lot more code...

  • #5
    New Coder
    Join Date
    Oct 2002
    Location
    Atlanta
    Posts
    28
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Just thought I'd mention this:

    For giggles, I checked out the Platform SDK on the TR tag, to find that IE does not support a Style or Attribute of type Border for that object.

    That would probably explain why it's not working ...

    Regardless of that, sounds like you have found a reasonable solution ...



  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •