Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5

Thread: <embed>

  1. #1
    New Coder
    Join Date
    Oct 2002
    Location
    Go CANADA!
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts

    <embed>

    http://www.geocities.com/noenera/Sha...dow_iframe.htm


    A page I am playing with:

    ----
    When this page loads, you will hear a short music clip.
    Problem being:
    It only plays once when I have it coded to repeat. I have other pages with the exact same code as below that repeat with no problems.

    Is anyone else having this problem...? and if so, can I do anything or is it just something to do with browsers and preferences?


    -----><embed src="DA_MagicStore_2.mp3" width="32" height="32" autostart=TRUE HIDDEN loop=-1><------

    -thanks-
    Be ReActive.

  • #2
    Senior Coder
    Join Date
    Aug 2002
    Posts
    3,467
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Only thing that looks improper to me is the attributes are missing double quotes...What DOCTYPE are you using?

    <embed src="DA_MagicStore_2.mp3" width="32" height="32" autostart="true" hidden="true" loop="-1">
    My Site | fValidate | My Brainbench | MSDN | Gecko | xBrowser DOM | PHP | Ars | PVP
    “Minds are like parachutes. They don't work unless they are open”
    “Maturity is simply knowing when to not be immature”

  • #3
    New Coder
    Join Date
    Oct 2002
    Location
    Go CANADA!
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Edited the code, added the missing values and quoted those that weren't.

    And actually, I didn't even have a DOCTYPE. I used Dreamweaver 4 to create all my pages - if that helps any.

    Also, I opened one of my other pages that I had done with this code, and now that isn’t working. I hate this : P

    I have another small site under a different account name, and the embed tag is used, using a streaming music URL. The same exact embed code is also used, only without the suggested changes:
    ::Ta-Da::
    <embed src="http://play.mp3.com/cgi-bin/play/play.cgi/AAICQuthJADABG5vcm1QBAAAAFJPJgIAUQEAAABDO5uSPfovxIHheLH2ZtKP7UvsSAs-/Where_Is_Trontown.m3u" width="32" height="32" autostart=TRUE HIDDEN loop=-1>
    -----------------------------------------------
    And it loops! I guess it might have to do with what you are looping? It really shouldn't, but it's a hunch...

    I added this DOCTYPE to the pages on the small web site currently in question:

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

    Just a side note, when I open these files on my local drive, everything works fine.. it repeats and thus no problems.. could geocities have codes (you know those ads) that are conflicting with my code? somehow...

    I appreciate the help so far
    Be ReActive.

  • #4
    New Coder
    Join Date
    Oct 2002
    Location
    Go CANADA!
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I made up a new page using the exact! embed code as above with the edits suggested::

    www.geocities.com/noenera/Grevan/Grevan.htm

    Only this time, the scr is a streaming URL music link (loFi for anyone who doesn't have DSL etc. connections) and the music LOOPS!!! Mind you, I made sure to pick a song that was over 6 mins long

    So.. all in all.. I think it does have to do with the type of file used?? or perhaps just being live, the song file hates having to repeat itself
    Be ReActive.

  • #5
    New Coder
    Join Date
    Oct 2002
    Location
    Go CANADA!
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts
    And here's the answer, thanks to marion (at http://siteownersforums.com/)

    The problem was fixed by::

    loop="-1" worked only for the Streaming Links, not song files.

    loop="true " worked for both Streaming AND Song files!


    Thanks for any help I did get here
    Be ReActive.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •