Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New to the CF scene
    Join Date
    Aug 2005
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exclamation Problem with targetting iframe using Xara menu?

    Hello all,

    I'm just trying to get a html pageto open up in an iframe!!!

    I am creating a website using a Xara Webstyle 4 template.

    On the page, I have a table, and within that, the Iframe which is called main:

    Code:
    <iframe name="main" width="100%" height="600" src="main.htm" scrolling="yes" border="0" frameborder="0"></iframe>
    On the horizontal navbar I have changed the Javascript to:

    Code:
    ;writeButton(loc+"../","main.htm","main","index_hnavbar_b6",84,20,"Home","",0)
    It's opening up the main.htm file in a blank window as if I've used a target="_blank" command.

    I'm just trying to get that main.htm to open up in the iframe!!! PLEASE HELP ME!!! I've tried putting target commands after it, but then the whole navbar disappears (I presume thats down to the Javascript).

    Any thoughts would be GREATLY appreciated!!!

    Please email bassjunkie@gmail.com

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Without really seeing the script I can only guess that you have the target in the wrong spot. Try
    Code:
    ;writeButton(loc+"../","main.htm","","index_hnavbar_b6",84,20,"Home","main",0)
    ||||If you are getting paid to do a job, don't ask for help on it!||||


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •