Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3

Thread: Error messages

  1. #1
    Regular Coder CurtWRC's Avatar
    Join Date
    May 2005
    Location
    UK
    Posts
    224
    Thanks
    9
    Thanked 1 Time in 1 Post

    Error messages

    Does anyone know why error messages appear when I load the homepage of my site ( www.rallystuff.net ). It says there is an error on line 98 twice and one on line 582.

    Any help would be much appreciated,
    Thanks,
    Curt

  • #2
    Senior Coder JamieR's Avatar
    Join Date
    Oct 2004
    Location
    United Kingdom
    Posts
    3,161
    Thanks
    0
    Thanked 5 Times in 5 Posts
    What the expected ; JS errors in IE? I dunno really what they mean, but I think expected ; means that it is missing a ; on that line, as unexpected ; would mean a ; that shouldn't be there, I think.

  • #3
    Banned
    Join Date
    Sep 2003
    Posts
    3,620
    Thanks
    0
    Thanked 0 Times in 0 Posts
    LINE 99:

    Code:
    99:     <span class="style21"><span class="style25"><span class="style27"><span class="style28"><span class="style29"><span class="style25"><span class="style27"><span class="style25"><span class="style26">  <span class="style26"><a href="Dukeries%20Rally%202005.htm">New Images: Dukeries Rally 2005 <span class="style21"><a href="http://rallystuff.proboards44.com/index.cgi?board=general&action=display&thread=1119890854" ONMOUSEOVER="Click Here to enter the current rallystuff competition';return true" target="_blank">-</a></span></a></span></span></span></span></span></span></span></span> </span><span class="style21"><span class="style25"><span class="style27"><span class="style28"><span class="style29"><span class="style25"><span class="style27"><span class="style25"><span class="style26"><a href="http://rallystuff.proboards44.com/index.cgi?board=general&action=display&thread=1119890854" ONMOUSEOVER="Click Here to enter the current rallystuff competition';return true" target="_blank">rallystuff WRC Argentina competiton - Deadline: 14/07/2005 </a><span class="style34">●</span> <a href="WRC%20Greece%202005.htm">WRC Greece 2005 Full Report </a></span> </span></span></span></span></span></span></span></span>
    The problem is with both of your mouseovers opening with double quotes and closing with single quotes...

    LINE 583:

    Code:
    583:     <div id="Layer10" style="position:absolute; width:200px; height:115px; z-index:14; left: 294px; top: 15px;"><a href="http://www.rallystuff.net" ONMOUSEOVER="rallystuff.net - No1 for rally on the net" target="_blank"><img src="Banner7.gif" width="453" height="109" border="0"></a></div>
    Although the quotes here are correct, as with above your mouseovers... It/they are NOT doing anything... If you are trying to set a statusbar message you are not only going about it wrong but it is not recommended since visitors expect to see where the link goes too... Masking the link with statusbar messages will more likely than not drive visitors away... Besides, many browsers disallow these statusbar messages... Get rid of them and your problems will be solved...

    .....Willy


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •