Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New to the CF scene
    Join Date
    Jul 2005
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    need charset help.

    I installed a "Rate me script" on my site. (www.gat101.co.il/hotornot) I put a title and a few words in Hebrew (since I want to translate the script to hebrew) I have also changed ALL places in ALL files of the script where there was a definition of charset to charset=ISO-8859-8-I since this is the Hebrew one. Now, when open my page the words that are supposed to be Hebrew are "Jibrish". I take a look into the source via IE view/source and it says It changes the -8 to -1 !!! Of course if I choose via IE view/encoding/Hebrew(Windows) it changes fine and I see the Hebrew, but every time I reload the page, it switches back to "jibrish". (the view/encoding switches to "Western
    European (Windows) ) How can I make that it should ALWAYS be the charset I want? I did a text search in ALL the script files and NO WHERE does it have ISO-8859-1 - so why is it changing to that?

    Thank you

  • #2
    Senior Coder
    Join Date
    Jul 2004
    Location
    New Zealand
    Posts
    1,315
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Your server (and for IE the page itself) must be set up to send the appropriate character set and encoding.
    Forget style. Code to semantics. Seperate style from structure, and structure from behaviour.
    I code to specs, and test only in Firefox (unless stated otherwise).


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •