Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    New to the CF scene
    Join Date
    May 2005
    Location
    Holland MI
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy Really odd problem...

    Hello,

    First time on the forum so I'm sorry if I step on toes, I'll try and do better in the future!

    My problem is I think, that my css file won't load. I've tried it on 1 mac and 2 PC's with the same result and it just seems to not be loading my style sheet. I've been frustrated with this since around noon yesterday with no luck fixing it. And to make things even weirder (Maybe) my normal style sheet works and loads just fine. If there is anyone out there that could help me I would greatly appreciate it!

    Jason Pruim
    Production & Technology Manager
    Raoset Inc.
    JApruim@nospam.raoset.com <-------Just remove "the nospam." part.

    HTTP://www.raoset.com/index.shtml <----------- Web page
    HTTP://www.raoset.com/media/redesign.css <----- CSS file

    The menu at the top of the screen is supposed to be a deep red box with the links inside it. and the "statement of confidentiatlly" header is supposed to match the red. Any comments as far as how sucky my code is is appreciated as long as it's constructive. I really want to get better but I'm teaching myself and learning as I go.

  • #2
    Regular Coder
    Join Date
    May 2005
    Posts
    563
    Thanks
    0
    Thanked 3 Times in 3 Posts
    try putting the link to the css file under your meta tags.

  • #3
    New to the CF scene
    Join Date
    May 2005
    Location
    Holland MI
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Same result. Could it be that the code doesn't validate 100%? There is a small section of the CSS that won't validate and I have no idea why? Although that shouldn't totally break the entire sheet just that particular element yes?

  • #4
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    The likely cause is the "comments" you are trying to use in your css file.
    Code:
       <!--Code for statement of confidentially
    -->
    is not a valid comment for CSS, a valid comment would appear like so,
    Code:
    /*Code for statement of confidentially*/

  • #5
    New to the CF scene
    Join Date
    May 2005
    Location
    Holland MI
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Changed all the comments from HTML comments to CSS comments, still the same result...

    So I ran it through the w3c's validator. and it spit this out and I can't find the errors my self, or at least how to fix them. Could this be causing the problem?

    Line: 12 Context : p.state

    Parse Error - ;) body { font-family: Helvetica, serif; color: black; background: white; margin-left: 5%; margin-right: 5%; }


    Line: 26 Context : Code for text position

    Parse Error - --> body div.text { display: none }


    Line: 107 Context : Code for statement of confidentially

    Parse Error - --> div.statement {text-align: center; margin-top: 2.5em; border-top: 5px solid black; border-bottom: 5px solid black; border-left: 5px solid black; border-right: 5px solid black; color: black; background: white; font-size: 85%; padding-top: 0em; padding-bottom: 0em; padding-left: 1em; padding-right: 1em; letter-spacing: 1px;}


    Line: 128 Context : Code for header on top of screen

    Parse Error - --> div.nav { display: none }

  • #6
    New to the CF scene
    Join Date
    May 2005
    Location
    Holland MI
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Okay... So I think I narrowed it down to being a problem with the navigation div and the text div. When I copied individual parts of the style sheet into another sheet for testing it worked until I put those sections in. Weird huh? All the code in those 2 sections validate so it's all valid, can't find anything that says to me this is wrong, no flags....

  • #7
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    ha! its not valid

    Code:
    p.state {font-size: 85%; padding-left:1em; padding-right: 1em; padding-top: 0em; border-top: 3px solid black;  border-bottom: 3px solid black; border-left: 3px solid black; border-right: 3px solid black;)
    You closed off a style with a ) and not a }


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •