Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Dec 2004
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    div height not recognized until refresh

    hello,

    the site i'm developing uses an invisible div just to the right of my content text to set a sort of min-height for my content side of the site.

    http://www.thelastlight.net/lcotc/

    if you click on 'about us' or any areas that don't have enough content to push the content div (white bg) down to at least where the dashed line meets up with the bottom of the large teal graphic in the middle of the site, the invis div should force the height.

    i'm finding that in IE6 sometime it works and sometimes not while clicking around. in fact if you click the about us link it will even toggle betweeb working and not working. but...if i hit refresh it will snap to the correct length.

    any ideas?

    in firefox the site behaves perfectly.

    thanks for any help you guys can give me.

    brett

  • #2
    New to the CF scene
    Join Date
    Dec 2004
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    i also just noticed that when the content window doesn't expand properly, if i right click on the small teal shape to the left of the content title and select properties...the window all of a sudden snaps to it's proper height!?

  • #3
    Senior Coder
    Join Date
    Apr 2003
    Location
    Canada
    Posts
    1,063
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Doesn't look like a coding error to me. This right click property really shouldn't affect the page at all. I think it may simply be a bug, or maybe it's your computer. I know I've had some strange problems because my graphic card was slow...
    Shawn

  • #4
    Regular Coder
    Join Date
    Nov 2003
    Location
    Vancouver Island Canada
    Posts
    139
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Usually erratic behaviour in IE is caused be not having a doctype declaration. I noticed you don't and would recomend using one. I've run into a similar problem in the past and using a doctype fixed it. Hope that helps.

  • #5
    New to the CF scene
    Join Date
    Dec 2004
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    thanks for the replies. after beating myself up for more than a day i've done the unthinkable. i've used a 2 column table with the left column reserved for a vertical spacer image. ugly but it works. wish the document tag had worked!

    cheers.

    brett

  • #6
    Senior Coder
    Join Date
    Nov 2003
    Location
    Minneapolis, MN
    Posts
    2,879
    Thanks
    2
    Thanked 65 Times in 56 Posts
    Well, IE treats height like min-height, so you might be able to use that to your advantage. Instead of the invisible div, try something like this (I'm making up numbers and ids here, but I'm sure you'll get the drift):
    Code:
    #container {
     height: 500px;
     }
    
    html > body #container {
     height: auto;
     min-height: 500px;
     }
    Maybe?


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •