Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2

Thread: Whats happening

  1. #1
    New Coder
    Join Date
    Oct 2004
    Location
    Sydney
    Posts
    62
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Whats happening

    http://www.finser.com.au/_mda/build_1.html

    Hi new to CSS as the source code will show. 1st CSS site. So having some issues...

    My #nav and #centre don’t seem to align to the centre of the browser in IE.

    Also ive made some horizontal buttons which are meant to sit inside the #nav but they seem to have some funny spacing between them... I played around with margin and border to no avail.

    So now the coloured bits on top of the buttons don’t line up anymore with this button spacing thing. Also IE is ignoring the height...

    All the CSS & html is in the page source....

    Actually my attempts at structure here will probably entertain most of you to no end...


    Any pointers her will be a big help...
    cam

  • #2
    Senior Coder whizard's Avatar
    Join Date
    Jan 2005
    Location
    Philadelphia, PA, USA
    Posts
    1,662
    Thanks
    14
    Thanked 76 Times in 76 Posts
    Also ive made some horizontal buttons which are meant to sit inside the #nav but they seem to have some funny spacing between them... I played around with margin and border to no avail.
    If you mean the white lines between the gray <a> boxes, that is becasue of this line in your CSS:

    Code:
    a.menu{
    	width :115px;	
    	height: 30px;
    	text-align : left;
    	font-family: Verdana;
    	font-size : 9pt;
    	color : white;
    	text-decoration : none;
    	background-color :#666666;
    	padding: 10px 0 0 5px;
    	border: solid 1px white;  
    	margin: 0px;
    This is fixed by resetting "solid 1px white" to "solid 0px white", or by removing the line. (I'm not sure if this is your problem)

    Also, don't use absolute positioning for your layout. set them to relative, from inside a wrapper div that is absolutely positioned. This could be why the colors aren't lining up.

    Dan
    PHP Tip: If you want to use short tags (<? or <?=$var) then make sure short_open_tag is set to "1". It really helps.

    Don't forget to save everyone time and mark your thread as Resolved :)

    "Also note that it is your responsibility to die() if necessary."

    DON'T USE THE MYSQL_ EXTENSION


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •