Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New Coder
    Join Date
    Jun 2002
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Simple HTML tag problem

    I've created two pages, one called page1.html and one called page2.html
    On page2.html I have created a tag at the bottom of the page like this
    <a name="bottom">

    Then on page1.html I created the link to go TO the tag like this:
    <a href="page2.html#bottom">bottom of page 2</a>

    It works fine in Netscape but in IE5.0 it comes up with a page error saying that
    "The page cannot be displayed" and it's looking for page1.html

    What's the deal on this? What am I missing???

  • #2
    New Coder
    Join Date
    Jun 2002
    Location
    Central Ohio
    Posts
    34
    Thanks
    0
    Thanked 0 Times in 0 Posts
    You need to create the Anchor like this...

    Code:
    <html>
    <head>
    </head>
    <body>
    <p>This is your body of the page.</p>
    ...
    <p>This is the last line on the <a name="bottom">page</a>.
    </body>
    </html>
    You have to wrap that anchor around something.

    Jer!
    Jers-Web, Inc.
    Ever seen 49,825 Alert Boxes on one page? I have!

  • #3
    Regular Coder
    Join Date
    Jun 2002
    Posts
    344
    Thanks
    0
    Thanked 0 Times in 0 Posts
    actually, you just need to end the anchor tag...

    jwoods - all you did was start the tag '<a name="bottom">'

    you need to close it... so writing this would be fine:

    <a name="bottom"></a>

    that's all you need. That'll work in any browser.

    ~Quack

  • #4
    Regular Coder
    Join Date
    Jun 2002
    Location
    United Kingdom Confused: Often
    Posts
    859
    Thanks
    0
    Thanked 0 Times in 0 Posts
    it always worked for me in IE 5....
    redhead

  • #5
    New Coder
    Join Date
    Jun 2002
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Does it work now, if not replace the page2.html#bottom with the correct http://www.whatever.com/page2.html#bottom try that and if it don't work then you'll need to ask a more experienced person in this.

  • #6
    New Coder
    Join Date
    Jun 2002
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I placed the tag around text like this
    <a name="bottom">Bottom of page</a> and it does the same thing.

    It works when I upload it to my server and look at it over the internet instead of locally on my computer. That must be the reason...not sure why but at least it works! It's all I need it to do anyway!

    Thanks for the help!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •