Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New Coder
    Join Date
    Jan 2005
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    CSS and table incorrect display

    Hi.
    Will you please help me with this problem I have. I am using a CSS script below

    <style type="text/css">
    <!--
    A:link {text-decoration: none;}
    A:visited {text-decoration: none;}
    a:hover {text-decoration: none; color:#CC9900}

    .{margin-left: 6%; margin-right: 6%;}
    -->
    </style>

    When I use a table 1 row 3 cols and add text all looks good in IE, well until I make the text within the table cells into text links and then the 3 text links spread out which I don't understand and want because my table is set at 30%. When I cut out the css the table shows correctly. I am loking for a webpage that will margin in a little from the left and the right and i have been hours trying to fathom this out ...ARGGG. I cannot begin to start my webpage until this problem is ironed out. Any help I would appreciate. Thanks

    Chris

  • #2
    Senior Coder
    Join Date
    Jun 2002
    Location
    The Netherlands, Baarn, Ut.
    Posts
    4,252
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Markup?

    There's no giving definitive answers without a look at the page markup ("code") as well; can you either supply a link to the page online (preferred) or an exact copy/paste in here?

    For the time being, I'd like to make two observations:
    1. Two of the rules for anchors use A (uppercase) as selector and the third uses a (lowercase); I'd strongly recommend using either lowercase or uppercase consistently, depending on what is used in the markup (for forward compatibility, it's advised to go for all lowercase since XHTML requires this).
    2. What is this rule supposed to do?
      Code:
      .{margin-left: 6%; margin-right: 6%;}
      I don't see a valid selector (All classed elements? Empty class attributes? Can't be right).
    Regards,
    Ronald.
    ronaldvanderwijden.com


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •