Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Jan 2005
    Location
    Australia
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Trouble with layers not showing with show/hide layers, help needed.

    As the topic title says, the Dreamweaver show/hide layers script isn't working properly, and I don't know why. Basically, only one layer will show (Layers controllered via CSS), and I haven't been able to get *any* other layers to show at all, yet one layer works fine from any link.

    I'd appreciate any/all help on the subject, as I originally wanted my whole site based around showing/hiding layers.

    Html page; http://zen-ith.com/main.htm
    CSS file; http://zen-ith.com/style.css

    Cheers.

  • #2
    Senior Coder
    Join Date
    Nov 2003
    Location
    Minneapolis, MN
    Posts
    2,879
    Thanks
    2
    Thanked 65 Times in 56 Posts
    Hello, welcome to the forums.

    Using a Dreamweaver script is one option... if so this is a Javascript problem and you should ask a moderator to move your post to the appropriate forum (don't crosspost!).

    You might be able to accomplish this using CSS only, however, so if that's an option (i.e. you feel comfortable straying from Dreamweaver for a bit) stay in this forum and we'll help you figure it out.

  • #3
    New to the CF scene
    Join Date
    Jan 2005
    Location
    Australia
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The thing is, I'm not sure whether it's an issue with the Java, or whether it's something else in my html code/css that's messing things up. Therein lies the problem. I've tried messing with Z-indexes, and nothing... So yeah.

    Edit:: Thanks for the welcome too, by the way. And yeah, I'd be interested in looking at alternatives to Dreamweaver scripts, and using CSS properly, but keep in mind I'm a n00b, but I'm always open to learning new things.
    Last edited by Zenith; 01-16-2005 at 09:14 AM.

  • #4
    Senior Coder
    Join Date
    Nov 2003
    Location
    Minneapolis, MN
    Posts
    2,879
    Thanks
    2
    Thanked 65 Times in 56 Posts
    whoops, I missed the fact that you are wanting the layer to appear when the link is clicked. You are definitely going to need some javascript to do what you are looking for, unless you put each layer in a separate file.

    I'd ask the mod to move this to the JS forum, although I'm sure you'll get a bit of hassle for using a DW script

  • #5
    New to the CF scene
    Join Date
    Jan 2005
    Location
    Australia
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Anyone? Anyone at all? This is really frustrating me, and I still can't figure out what's wrong.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •