Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 11 of 11
  1. #1
    Regular Coder
    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    234
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Forms and lists have space below them

    All my <form> tags and <li> tags seem to have an extra line of transparent space below them, but only in I.E.

    Is this a regular occurence? How can I get rid of it?

    CSS:

    Code:
    #loginbar {
    	background-color: #B57B46;
    	width: auto;
    	padding: 1px;
    	font: bold 10px Arial, Helvetica, sans-serif;
    	color: #000000;
    	margin-bottom: 1px;
    	text-align: right;
    	height: 16px;
    	font-weight: bold;
    }
    
    input.loginbar {
    	background: #cccccc;
    	color: #000000;
    	border: 1px solid #000000;
    	font: bold 10px Arial, Helvetica, sans-serif;
    	height: 14px;
    	width: 50px;
    	vertical-align: middle;
    }
    HTML:

    Code:
      <div id="loginbar"> 
        <form name="login" method="post" action="index.php?process=login">
          <input name="u" type="text" class="loginbar" />
          <input name="p" type="password" class="loginbar" />
          <input name="l" type="submit" class="loginbar" value="Login" />
        </form>
      </div>
    Thanks!
    Dave

  • #2
    Senior Coder
    Join Date
    Aug 2002
    Location
    Kansas City, Kansas
    Posts
    1,518
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Try applying margin-bottom: 0; and padding-bottom: 0; to the elements.

  • #3
    Regular Coder
    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    234
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hmmpft... Didn't work, If anyone is interested the site can be found at http://www.veneratiohq.org/index.php

    I know the coding is probably terrible, and the page looks terrible... but its only for a few friends I know, so I'll pretty it up once it works.

    Any other ideas?
    Last edited by newmand2; 10-05-2004 at 04:08 PM.
    Dave

  • #4
    Regular Coder
    Join Date
    Jul 2004
    Location
    engoku no anime
    Posts
    354
    Thanks
    0
    Thanked 0 Times in 0 Posts
    mysql error

    Warning: mysql_connect(): Access denied for user: 'newmand2_arbiter@localhost' (Using password: YES) in /home/newmand/public_html/conn.php on line 5
    Unable to connect to MySQL

  • #5
    Regular Coder
    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    234
    Thanks
    0
    Thanked 0 Times in 0 Posts
    sorry about that... I was in the middle of switching servers - all works fine now

    http://www.veneratiohq.org/index.php
    Dave

  • #6
    Senior Coder
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    1,223
    Thanks
    0
    Thanked 0 Times in 0 Posts
    IE mishandles whitespace on li elements.

    Try removing whitespace after </li> like so:

    Code:
    <ul>
      <li>List Item</li><li>
      List Item</li><li>
      List Item</li><li>
      List Item</li><li>
      List Item</li><li>
      List Item</li><li>
      Last Item</li>
    </ul>
    It's sort of ugly, but it works

  • #7
    Regular Coder
    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    234
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks worked a treat...

    Can I do anything about the <form> tag?
    Dave

  • #8
    Senior Coder
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    1,223
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The form tag's spacing is probably just a margin. Also, check that it's not the margin of a containing element that's pouring out.

    If form { margin: 0; } doesn't fix it, but form * { margin: 0; } does, then it's something inside it.

  • #9
    Regular Coder
    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    234
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks so much

    however... i seem to have an extra 'thing' below the menu... the other blue bar thing? I'm guessing its the whitespace again?
    Dave

  • #10
    Senior Coder
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    1,223
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I left it as:

    Code:
      </li>
    </ul>
    But you may want to make it

    Code:
    </li></ul>
    Might fix it?

  • #11
    Regular Coder
    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    234
    Thanks
    0
    Thanked 0 Times in 0 Posts
    thanks - sorted it just as you posted

    thanks for the help everyone
    Dave


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •