Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    Jun 2011
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Anchor issue in Firefox

    Hi, I have an issue with anchors in Firefox and I'm struggling to find a solution. Anchors on the same page work fine, but where I link to another page and want to include an anchor, that is where I have the issue.

    If you go to one of the pages other than the home page (e.g. Dan Gallagher Photography - Birmingham based photographer - Bump shoots) and then click on one of the navigation options on the menu at the top of the page, it is supposed to take you back to the home page, straight to the anchor I've included in the URL.

    This works absolutely fine in IE and Chrome, but in Firefox it doesn't seem to recognise the anchor. The URL in the address bar correctly shows the URL with the correct anchor included (e.g. Dan Gallagher Photography - Birmingham based photographer) but it does not take the user to the right section of the page.

    I've read lots of discussion about this issue but I can't seem to find a solution that works - does anyone have any ideas?

  • #2
    Senior Coder
    Join Date
    Jan 2011
    Location
    Missouri
    Posts
    4,226
    Thanks
    23
    Thanked 606 Times in 605 Posts
    Works for me, FF ver 28.0 Clear your cache. Maybe an add-on causing it?
    Evolution - The non-random survival of random variants.

    "If you leave hydrogen alone, for long enough, it begins to think about itself."

  • #3
    New to the CF scene
    Join Date
    Jun 2011
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by sunfighter View Post
    Works for me, FF ver 28.0 Clear your cache. Maybe an add-on causing it?
    Thanks for your reply. I've cleared everything and I still see the issue and I don't have any add ons as I only just installed Firefox to test this issue as I was using Chrome.

  • #4
    Senior Coder
    Join Date
    Jan 2011
    Location
    Missouri
    Posts
    4,226
    Thanks
    23
    Thanked 606 Times in 605 Posts
    OK I re-read you post and tried it again and you are correct, this is a problem with FF. I originally hit "home" But any of the others takes me to half-way down services. I'm gonna guess that it has something to do with the page being rendered in php and not a html.
    Evolution - The non-random survival of random variants.

    "If you leave hydrogen alone, for long enough, it begins to think about itself."


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •