Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New to the CF scene
    Join Date
    Aug 2013
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exclamation Menu and other problems with IE!

    Hey guys,

    First post here

    Having some problems with a website I am trying to complete for someone.

    Please visit

    www.sciafrica.net/sci

    In Firefox and Chrome, no issues with the main menu.

    In IE the last item 'About Us' falls to the next line and sometimes the page does not open - gives me an error 'Element does not exist in DOM'

    How can I solve these problems with IE?

    Everything else seems fine. If any one has any other advice, please do share

    Thanks,

    Issh

  • #2
    Senior Coder
    Join Date
    Jan 2011
    Location
    Missouri
    Posts
    3,762
    Thanks
    23
    Thanked 548 Times in 547 Posts
    You should validate your code here http://validator.w3.org

    <li id="menu-item-1"> on line 175 and 77 Only one ID per script! You also have <li id="menu-item-2" > twice or more.
    A second <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://… line 63.

    Correct the errors and then see if script works cross-browser.

    Your error show up here http://validator.w3.org/check?uri=ww...Inline&group=0
    Evolution - The non-random survival of random variants.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •