Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    Regular Coder
    Join Date
    Nov 2011
    Posts
    138
    Thanks
    12
    Thanked 0 Times in 0 Posts

    Question a href not clickable?

    Hi there,
    I'm assuming this is a CSS or HTML issue, though I concede that I could well be wrong.

    This WordPress homepage has a sidebar with two circles in the sidebar. Both have links within them, but for some reason neither is clickable (though I've added the hands to the hover effect). I'm not sure why. I've tried playing with the z-index, but haven't had any luck. Perhaps it has to do with the :before border effect? I don't know.

    Also, the same mouseoever effect on these 2 circles next to the slideshow used to be in effect on the two circle images below the slideshow ("About" and "Events"), but it's not happening any more. I'm a little puzzled as to when that happened.

    Thanks in advance.

    ~Laura

  • #2
    The fat guy next door VIPStephan's Avatar
    Join Date
    Jan 2006
    Location
    Halle (Saale), Germany
    Posts
    8,665
    Thanks
    6
    Thanked 1,006 Times in 979 Posts
    Yeah, it’s the :before style overlapping the anchor because it’s positioned absolutely while the anchor is “auto” (which is “static”). You need to assign position: relative and a z-index higher than the one of the generated content (“2” should suffice) to the anchor.

  • #3
    Regular Coder
    Join Date
    Nov 2011
    Posts
    138
    Thanks
    12
    Thanked 0 Times in 0 Posts
    Ahhhhh...thank you awfully much. It seems as if I may need to either eliminate the :before altogether or figure out a way to create some invisible content for it. I suspected the little trick there might get me in a bit of trouble.

    ~Laura

  • #4
    The fat guy next door VIPStephan's Avatar
    Join Date
    Jan 2006
    Location
    Halle (Saale), Germany
    Posts
    8,665
    Thanks
    6
    Thanked 1,006 Times in 979 Posts
    No, why? You don’t need to remove the generated content. As I said, just apply position: relative; and z-index: 2 to the link inside that circle/box.

  • #5
    Regular Coder
    Join Date
    Nov 2011
    Posts
    138
    Thanks
    12
    Thanked 0 Times in 0 Posts
    Oops, I missed the anchor part of the instructions. Sorry 'bout that. Ok. Working on getting that back to where it was.

  • #6
    Regular Coder
    Join Date
    Nov 2011
    Posts
    138
    Thanks
    12
    Thanked 0 Times in 0 Posts
    Thank you thank you! That certainly solved it!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •