Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    Regular Coder
    Join Date
    Apr 2012
    Location
    St. Louis, MO
    Posts
    985
    Thanks
    7
    Thanked 101 Times in 101 Posts

    Question Form within iframe: odd behaviour for input element

    Hello, everyone.

    I've got a weird issue that has myself and a designer a bit confused.

    I'm working on a page that has a form, and within this form is an iframe that contains another form. This iframe form is for file uploads, so you can upload one file after another, over and over, without reloading the whole page.

    Both form documents (job.cfm which contains the iframe which src is uploadfile.cfm) are loading the same CSS files.

    Upon initial page load, one of the form elements in the iframe (input type="text") is "taller" than the others by 8 pixels. When the form submits and refreshes, that same form element is properly sized.

    I tried applying a style to that one element and setting it to the same size as the other elements. Upon initial load, that worked; but when the form submits, the element is now SMALLER than the other elements.

    Can someone please explain to me what is going on???

    TIA,
    ^_^

    If anyone knows of a website that can offer ColdFusion help that isn't controlled by neurotic, pedantic jerks* (stackoverflow.com), please PM me with a link.
    *
    The neurotic, pedantic jerks are not the owners; just the people who are in control of the "popularity contest".

  • #2
    Regular Coder
    Join Date
    Apr 2012
    Location
    St. Louis, MO
    Posts
    985
    Thanks
    7
    Thanked 101 Times in 101 Posts
    Anyone? If you need sample code, I can try to type as much as possible. Copy/paste is not an option, unfortunately.
    ^_^

    If anyone knows of a website that can offer ColdFusion help that isn't controlled by neurotic, pedantic jerks* (stackoverflow.com), please PM me with a link.
    *
    The neurotic, pedantic jerks are not the owners; just the people who are in control of the "popularity contest".

  • #3
    Regular Coder
    Join Date
    Apr 2012
    Location
    St. Louis, MO
    Posts
    985
    Thanks
    7
    Thanked 101 Times in 101 Posts
    Here is an example of what I have:

    index.cfm:

    Code:
    <link href="{css folder}/form.css" rel="stylesheet" />
    <link href="{css folder}/jobs.css" rel="stylesheet" />
    <form name="editTask" class="bootstrap">
        <input type="text" name="request" id="request" value="" />
    <!-- iframe -->    <iframe src="upload.cfm" name="uploadFiles" id="uploadFiles">Your browser does not support iframes.  Please upgrade your browser.</iframe>
        <input type="text" name="comment" id="comment" value="" />
    </form>
    upload.cfm:

    Code:
    <link href="{css folder}/form.css" rel="stylesheet" />
    <link href="{css folder}/jobs.css" rel="stylesheet" />
    <form name="uploadFile" class="bootstrap">
        <input type="file" name="fileToUpload" id="fileToUpload" />
        <input type="text" name="fileVersion" id="fileVersion" />
        <select name="classification" id="classification"><option value="">Select</option><option value="C">Confidential</option><option value="U">Unclassified</option></select>
    </form>
    The text input of the iframe has the same border, font color, and background color as the text inputs of the parent document; but when the page first loads, it is 8px "taller" than the text inputs of the parent document.

    When the form in the iframe is submit (to itself) and the iframe content reloaded, the iframe text input matches exactly (including height) of the text inputs in the parent document.

    Any thoughts on what might be causing this?

    Thank you, in advance,
    ^_^

    If anyone knows of a website that can offer ColdFusion help that isn't controlled by neurotic, pedantic jerks* (stackoverflow.com), please PM me with a link.
    *
    The neurotic, pedantic jerks are not the owners; just the people who are in control of the "popularity contest".

  • #4
    Regular Coder
    Join Date
    Apr 2012
    Location
    St. Louis, MO
    Posts
    985
    Thanks
    7
    Thanked 101 Times in 101 Posts
    Has ANYone else experienced this issue?
    ^_^

    If anyone knows of a website that can offer ColdFusion help that isn't controlled by neurotic, pedantic jerks* (stackoverflow.com), please PM me with a link.
    *
    The neurotic, pedantic jerks are not the owners; just the people who are in control of the "popularity contest".

  • #5
    Regular Coder
    Join Date
    Dec 2012
    Posts
    121
    Thanks
    15
    Thanked 1 Time in 1 Post
    Seriously I dont get on with iFrames, I gave up with my contact page and just styled the PHP page instead. Good luck sorry I couldnt help

  • #6
    Regular Coder
    Join Date
    Apr 2012
    Location
    St. Louis, MO
    Posts
    985
    Thanks
    7
    Thanked 101 Times in 101 Posts
    Bump. Has anyone had a form element in an iframe that appeared different from other elements upon page load, but then appeared correct when the form was submit?
    ^_^

    If anyone knows of a website that can offer ColdFusion help that isn't controlled by neurotic, pedantic jerks* (stackoverflow.com), please PM me with a link.
    *
    The neurotic, pedantic jerks are not the owners; just the people who are in control of the "popularity contest".


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •