Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Regular Coder
    Join Date
    Mar 2011
    Posts
    215
    Thanks
    10
    Thanked 1 Time in 1 Post

    Image not loading on website

    http://cfferns.com/products-page/ter...en-assortment/

    The rest of the images on this site seem to load, but this one won't and Im not sure why. I thought it was the name of the file as this issue has popped up before and it was a conflict in naming, but renaming it doesnt seem to help.
    Last edited by lmorales; 11-30-2012 at 11:55 PM.

  • #2
    Regular Coder LearningCoder's Avatar
    Join Date
    Jan 2011
    Location
    The Pleiades
    Posts
    923
    Thanks
    76
    Thanked 29 Times in 29 Posts
    I've had this very same issue actually and when I finally got the the bottom of it, it seemed I was using someImage.jpg when it should have been someImage.JPG. As you can imagine it was such a hard mistake to find.

    I know it is a long shot, but you never know.

    Regards,

    LC.

  • #3
    Regular Coder
    Join Date
    Dec 2010
    Posts
    424
    Thanks
    22
    Thanked 56 Times in 56 Posts
    You have not told us which image is not loading, or where it is suppose 2 be.

  • #4
    Regular Coder LearningCoder's Avatar
    Join Date
    Jan 2011
    Location
    The Pleiades
    Posts
    923
    Thanks
    76
    Thanked 29 Times in 29 Posts
    Its the small thumbnail type image on the page, if you click it it's meant to come up in a box (kinda like a prettyPhoto effect) but it just keeps saying 'Loading', whereas if you browse the site and find any other image, they load ok.

    Can you post the code to the images which pop up?

    Regards,

    LC.

  • #5
    Regular Coder
    Join Date
    Dec 2010
    Posts
    424
    Thanks
    22
    Thanked 56 Times in 56 Posts
    ohh , so the image wont load in the lightbox,
    i see now.

    From his description i thought he meant an image just wouldn't display right on the page.

  • #6
    Regular Coder
    Join Date
    Dec 2010
    Posts
    424
    Thanks
    22
    Thanked 56 Times in 56 Posts
    I can only assume that somehow on this page the javascript isnt loaded properly. As if i try that exact picture on a different page, it loads fine.

  • #7
    Regular Coder LearningCoder's Avatar
    Join Date
    Jan 2011
    Location
    The Pleiades
    Posts
    923
    Thanks
    76
    Thanked 29 Times in 29 Posts
    I thought that spent a while thinking which image he meant

    Judging by his src attribute it looks like he might be pulling the image from a database or definitely another source. And his href of where the image leads to is a directory.

    I'm not totally sure of your cause but maybe check the image name in the 'href' against the image name which loads up in the lightbox.(which i'm sure it must be declared somewhere else)..

    Regards,

    LC.

  • #8
    Regular Coder
    Join Date
    Mar 2011
    Posts
    215
    Thanks
    10
    Thanked 1 Time in 1 Post
    Sorry I wasnt more specific, its a wordpress page, and I think its an issue with the shopping cart... Heres the code Im seeing

    Code:
    			<div class='breadcrumb'>
    			<a href='http://cfferns.com/products-page/'>Central Florida Ferns</a> &raquo;
    							 	   
    					<a href='http://cfferns.com/products-page/terrariums/'>Terrariums</a> &raquo;
    				 
    							 
    					2&quot; Terrarium &amp; Mini Garden Assortment				 
    					</div>
    		
    		
    	<div>
    						<div>
    				<div class="textcol">
    										<div class="imagecol">
    						 	   
    								<a rel="2_Terrarium_&amp;_Mini_Garden_Assortment" class="thickbox preview_link" href="http://cfferns.com/wp-content/uploads/wpsc/product_images/Terranium_Assortment-2.jpg">
    									<img class="product_image" id="product_image_85" alt="2&quot; Terrarium &amp; Mini Garden Assortment" title="2&quot; Terrarium &amp; Mini Garden Assortment" src="index.php?image_id=142&amp;width=128&amp;height=128"/>
    								</a>
    						 
    					</div>
    					 
    		
    					<div class="producttext">
    						<h2 class="prodtitles"><span>2&quot; Terrarium &amp; Mini Garden Assortment</span><a class='wpsc_edit_product' href='http://cfferns.com/wp-admin/admin.php?page=wpsc-edit-products&amp;product_id=85'>Edit</a></h2>

  • #9
    Regular Coder LearningCoder's Avatar
    Join Date
    Jan 2011
    Location
    The Pleiades
    Posts
    923
    Thanks
    76
    Thanked 29 Times in 29 Posts
    Where does this 'src' lead to?

    Code:
    src="index.php?image_id=142&amp;width=128&amp;height=128"
    Because this is the initial image which is being shown on the page, so it could be that the 'correct' image name is located here, which could be different from this one:

    Terranium_Assortment-2.jpg

    Kind regards,

    LC.

  • #10
    Regular Coder
    Join Date
    Mar 2011
    Posts
    215
    Thanks
    10
    Thanked 1 Time in 1 Post
    Im not sure, I did not write the code, this is a wordpress site, I just have to fix it . Thats one of the reasons its kinda tricky.

  • #11
    Regular Coder LearningCoder's Avatar
    Join Date
    Jan 2011
    Location
    The Pleiades
    Posts
    923
    Thanks
    76
    Thanked 29 Times in 29 Posts
    Ahh it's kinda tricky to help you bud because without the access to where the lightbox file is located, I'm not sure if it is the file name. It could be something completely different to be honest but I remembered having a very similar issue so I thought I may be able to help you out.

    Regards,

    LC.

  • #12
    Senior Coder DanInMa's Avatar
    Join Date
    Nov 2010
    Location
    Salem,Ma
    Posts
    1,577
    Thanks
    13
    Thanked 248 Times in 248 Posts
    ok, you are getting an error in console ( if you have no idea what im talking about, check out some of the links in my sig one is a debugging tutorial)

    PHP Code:
    ErrorSyntax errorunrecognized expression: [rel=2_Terrarium_&_Mini_Garden_Assortment]
    http://cfferns.com/wp-includes/js/jquery/jquery.js?ver=1.7.1
    Line 3 
    this means the object is being referenced incorrectly somehow or it could be an issue with the version of jquery, I'm trying to figure it out.

  • #13
    Regular Coder LearningCoder's Avatar
    Join Date
    Jan 2011
    Location
    The Pleiades
    Posts
    923
    Thanks
    76
    Thanked 29 Times in 29 Posts
    Just a thought but this line triggered my memory of prettyPhoto.
    [rel=2_Terrarium_&_Mini_Garden_Assortment]

    The array [rel=blabla] is used in the CSS of the prettyPhoto to determine the image to show. (or something similar, it's been a year or so since I last used prettyPhoto).

    I'm clutching at straws but the error that Dan has found could well be the issue.

    Good luck with it dude!

    Regards,

    LC.

  • #14
    Senior Coder DanInMa's Avatar
    Join Date
    Nov 2010
    Location
    Salem,Ma
    Posts
    1,577
    Thanks
    13
    Thanked 248 Times in 248 Posts
    try removing the rel attribute from the anchor link. I believe you should only be using a rel attribute with thickbox if it's part of a gallery, and this is a single image. Since your error is related to the rel attribute in the console, this must have something to do with it.

  • #15
    Senior Coder DanInMa's Avatar
    Join Date
    Nov 2010
    Location
    Salem,Ma
    Posts
    1,577
    Thanks
    13
    Thanked 248 Times in 248 Posts
    Quote Originally Posted by LearningCoder View Post
    Just a thought but this line triggered my memory of prettyPhoto.
    [rel=2_Terrarium_&_Mini_Garden_Assortment]

    The array [rel=blabla] is used in the CSS of the prettyPhoto to determine the image to show. (or something similar, it's been a year or so since I last used prettyPhoto).

    I'm clutching at straws but the error that Dan has found could well be the issue.

    Good luck with it dude!

    Regards,

    LC.
    nope.


    if you look at the thickbox.js code you will find it uses this.href to get the value of the the image to display, and the rel attribute to determine if the image is part of a gallery ( basically a group of links with the same rel attribute)


  •  
    Page 1 of 2 12 LastLast

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •