Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 11 of 11
  1. #1
    New to the CF scene
    Join Date
    Nov 2012
    Posts
    8
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Help with HTML codes for navbar dropdowns

    Hi. I'm new to this website. And new to html. I was wondering if someone would look at my website and please give me a code that would get rid of the ugly grey and black backgrounds on my navbar when you hover over the links. Here's my website: here Thanks very much.

    Also I have another question. I'm not sure if anyone will be able to answer it. About a week or two ago I added a skype button application to my sidebar, and then tried to put the link to my website onto my Facebook wall, and it started giving me a security code to put it up. I'm assuming it's from having the skype button on it. But I removed it that very day, and it's been almost 2 weeks now and it's still not fixing itself. Is there anyway that anyone can figure out how to fix it?

    Thanks again, very much.
    Elishiva

  • #2
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,672
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    Good morning Elishiva,
    You have a background image for the hover effect on that menu, img/menu-hover.png

    That image isn't there so, instead of your image, an "image not found" .gif loads instead. That's the black that you're seeing.
    The gray seems to be coming from a gradient background ... also on the hover but I can't seem to tell if it's on the anchor or the li.

    Check to make sure your path and spelling are correct for menu-hover.png.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #3
    New to the CF scene
    Join Date
    Nov 2012
    Posts
    8
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Excavator thanks so much for your reply. I do understand what you're saying, but I can't seem to find anything that even remotely says menu hover ping, to even try to correct it. Do you think that you could tell me how or where to find it? And if so, can you help me to figure out how to get rid of it? And the grey, could we change to pink? This is frustrating since I am barely touching the surface of learning css. I love how the websites going, this is the last step though, and Ive been struggling with it for a week now.

    Also, do you have any clue about the other thing I mentioned? The skype connection and how or what I'd do to actually get rid of it totally? I can't get thru to skype..ever. And my own website support stinks so bad that they keep telling me that they can't do a thing for me, and to contact skype. OY!

  • #4
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,672
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    Quote Originally Posted by Elishiva View Post
    Excavator thanks so much for your reply. I do understand what you're saying, but I can't seem to find anything that even remotely says menu hover ping, to even try to correct it. Do you think that you could tell me how or where to find it?

    In base.css, lines #188, #196 and #200
    Code:
    #fw-mainnavwrap ul ul li:hover {
    		background: transparent url(img/menu-hover.png);
    }
    
    #fw-mainnavwrap ul ul li a:hover {
    		background:none !important;
    }
    
    #fw-nav-menu a:hover {
    	background: transparent url(img/menu-hover.png);
    }
    
    #fw-nav-menu a.fw-current-nav-link {
    	background: transparent url(img/menu-hover.png);
    	display:block;
    }
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • Users who have thanked Excavator for this post:

    Elishiva (11-16-2012)

  • #5
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,672
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    Quote Originally Posted by Elishiva View Post
    Also, do you have any clue about the other thing I mentioned? The skype connection and how or what I'd do to actually get rid of it totally?
    I'm afraid I don't see a sKype connection in your sidebar on http://womenofturah.webs.com/
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #6
    New to the CF scene
    Join Date
    Nov 2012
    Posts
    8
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Is it safe to just remove those png's you highlighted in red? Or do I replace them with something?

  • #7
    New to the CF scene
    Join Date
    Nov 2012
    Posts
    8
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Here are the codes that I see. I don't see the hover pngs that youre referring to. Please help me straighten this out. Thanks so much.


  • #8
    New to the CF scene
    Join Date
    Nov 2012
    Posts
    8
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I dont see the background hover pngs that you're talking about. It's as if theyre in hiding or something. I pasted the css codes into pastee website and tried to paste the link to it here but it didnt work. I dont know how to get you the picture or the note with the codes that I see on it.

    *Edit. Sorry I didn't realize it had to be monitered and okay'd first before that one went up onto the site. So you'll eventually get the pastie site with the codes that I see.

    Again, thanks for your help.
    Last edited by Elishiva; 11-16-2012 at 09:17 PM. Reason: correction

  • #9
    New to the CF scene
    Join Date
    Nov 2012
    Posts
    8
    Thanks
    1
    Thanked 0 Times in 0 Posts

  • #10
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,672
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    That screencap you put up is showing .design.css
    The hover affects for your menu are found in base.css though I can't see from my end how that file is loaded.

    It looks like you've made the background all pink? It matches your color scheme now
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #11
    New to the CF scene
    Join Date
    Nov 2012
    Posts
    8
    Thanks
    1
    Thanked 0 Times in 0 Posts
    A friend of mine fixed it for me So I dont have any issues anymore. But thank you all you did to try to help! I do appreciate it alot.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •